Rasa Open Source 3.3 launched πŸš€

Hello Rasa Community!

I’m excited to announce that Rasa Open Source 3.3 has been released, and the docs have been updated. This launch includes a major improvement: Rasa supports native installations on Apple Silicon (M1/M2).

This also includes other updates like, continuous event export , caching message along with some bug fixes. You can find the full release notes here

10 Likes

Hi @sonam, did you or your team had issues while installing Rasa 3.3 on Mac M1? I tried it, I faced package installation error for grpcio. Below are logs for same.

Traceback (most recent call last):
        File "/private/var/folders/yp/n4b_22px4b592cw1fddmdnhm0000gn/T/pip-install-c2muo62g/grpcio_62c271f9e9c54cef8abda393504adcb3/src/python/grpcio/commands.py", line 280, in build_extensions
          build_ext.build_ext.build_extensions(self)
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/distutils/command/build_ext.py", line 449, in build_extensions
          self._build_extensions_serial()
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/distutils/command/build_ext.py", line 474, in _build_extensions_serial
          self.build_extension(ext)
        File "/Users/dishantgandhi/Desktop/hoory/hb-training-composer/venv/lib/python3.8/site-packages/setuptools/command/build_ext.py", line 196, in build_extension
          _build_ext.build_extension(self, ext)
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/distutils/command/build_ext.py", line 528, in build_extension
          objects = self.compiler.compile(sources,
        File "/private/var/folders/yp/n4b_22px4b592cw1fddmdnhm0000gn/T/pip-install-c2muo62g/grpcio_62c271f9e9c54cef8abda393504adcb3/src/python/grpcio/_parallel_compile_patch.py", line 58, in _parallel_compile
          multiprocessing.pool.ThreadPool(BUILD_EXT_COMPILER_JOBS).map(
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/multiprocessing/pool.py", line 364, in map
          return self._map_async(func, iterable, mapstar, chunksize).get()
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/multiprocessing/pool.py", line 771, in get
          raise self._value
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/multiprocessing/pool.py", line 125, in worker
          result = (True, func(*args, **kwds))
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/multiprocessing/pool.py", line 48, in mapstar
          return list(map(*args))
        File "/private/var/folders/yp/n4b_22px4b592cw1fddmdnhm0000gn/T/pip-install-c2muo62g/grpcio_62c271f9e9c54cef8abda393504adcb3/src/python/grpcio/_parallel_compile_patch.py", line 54, in _compile_single_file
          self._compile(obj, src, ext, cc_args, extra_postargs, pp_opts)
        File "/private/var/folders/yp/n4b_22px4b592cw1fddmdnhm0000gn/T/pip-install-c2muo62g/grpcio_62c271f9e9c54cef8abda393504adcb3/src/python/grpcio/commands.py", line 263, in new_compile
          return old_compile(obj, src, ext, cc_args, extra_postargs,
        File "/Users/dishantgandhi/miniforge3/lib/python3.8/distutils/unixccompiler.py", line 120, in _compile
          raise CompileError(msg)
      distutils.errors.CompileError: command 'gcc' failed with exit status 1
      
      [end of output]
  
  note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure

Γ— Encountered error while trying to install package.
╰─> grpcio

note: This is an issue with the package mentioned above, not pip.
hint: See above for output from the failure.

python version: Python 3.8.12

My group has also had continued problems installing on M1 Mac.

Hey @Horizon733, which method are you using to install rasa? Can you please share the command?

I briefly googled for β€œlegacy-install-failure pip grpcio” which seems to be the error you are getting. And some posts offer some advice, such as this one: grpcio error: legacy-install-failure with pip install [Fixed] | bobbyhadz. Can you first try to upgrade your version of pip, wheel, and setuptools using pip install --upgrade pip setuptools wheel? If that doesn’t work the post has some additional hints for Env vars on Mac.

Please let us know how it goes. I have installed the dependencies on my 2021 M1 multiple times the past days without any issues as I was working on upgrading some dependencies.

Hey @tomp,

do you mind sharing some specifics? We have multiple machines in the company and customers who are using M1 successfully.

@twerkmeister Sure, I tried the above method, but I still have the same issue, Macbook pro M1 I have is `Mac Ventura with 16gb. I am using venv for creating the environment. Can you please tell me what else you need to understand?

@twerkmeister It was a problem with installing this new Rasa package in the same environment as GCP packages. We are trying a different work-around, e.g., not installing GCP packages at all. I’ll see if we still have details to share.

Hey Dishant, did you have any luck so far getting around the compile error for grpcio? In the past some on our team got around compiler issues by reinstalling their pyenv environment again (so reinstalling the 3.8.12 environment not just creating a new venv inside of it).

hey @tomp, this seems not related to the grpcio compilation error above, right? Were you able to resolve or replicate the GCP conflict?

It may not be the same error. I just noticed that multiple people are still having trouble installing Rasa on M1 Macs despite their saying that the problems are fixed.

Sorry, I don’t have more details on my team’s installation problem. We were forced to time-box this path after spending so many days trying to install Rasa and GCP packages together without success. We are going a different route now.

Also having issues. Installation is successful but then get this (macOS Monterey 12.6)

Hi @twerkmeister, I’m also having trouble installing Rasa on my M1 (running Ventura 13.0.1).

I’ve been following the instructions listed here, but I’m not able to install all of the packages required for the environment (I copied the env.yml file linked to from the article). Like @Horizon733, I encountered a legacy-install-failure when installing grpcio (and my logs are basically the same).

I’ve already tried updating pip, setuptools, and wheel. I also tried explicitly setting the suggested environment variables, per the post you linked to. Other suggestions?