Rasa Open Source 3.1 and Rasa X 1.1 launched!

Hello Rasas! Rasa Open Source 3.1 and Rasa X 1.1 are now both launched and the docs updated! (Apologies for the slight delay with the latter.) You can find the full release notes for 3.1 here and for 1.1 here but the main updates are:

Rasa X 1.1

  • Rasa X is now compatible with Rasa 3.0+! We know this was highly requested and are very happy to have it live.

Rasa Open Source 3.1

  • We’ve added support for Python 3.9 and TensorFlow 2.7 (note that we can’t promise full backwards compatibility in terms of model reproducibility if you use LanguageModelFeaturizer)
  • We’ve added a raw format for specifying executed graph directly. Find more information on graph recipes here.
20 Likes

Thanks to much! :heart_eyes: :blue_heart: :raised_hands:

@rctatman Can you talk to Rasa team please don’t depreciate pip method installation of Rasa X? We have some issues with news methods :cry:

Can you read this topic in your free time?


I’m still get the alert.

Maybe because Apple M1 CPU?

Rasa Version      :         3.1.0
Minimum Compatible Version: 3.0.0
Rasa SDK Version  :         3.1.1
Rasa X Version    :         1.1.0
Python Version    :         3.8.12
Operating System  :         macOS-12.3.1-arm64-arm-64bit
Python Path       :         /Users/johnguimaraes/miniforge3/envs/rasatest/bin/python3.8
Your version of rasa '3.1.0' is currently not supported by Rasa X. Running `rasa x` CLI command with rasa version higher or equal to 3.0.0 will result in errors.
  rasa.shared.utils.io.raise_warning(
MissingDependencyException: Rasa X does not seem to be installed, but it is needed for this CLI command. You can find more information on how to install Rasa X in local mode in the documentation: https://rasa.com/docs/rasa-x/installation-and-setup/install/local-mode

It’s working with rasa 2.8.27 and Rasa X 1.0.1

3 Likes

Please add support for slack. In Slack (with Rasa bot connected), custom actions which require more than 3 seconds to run die out and don’t send desired response back to slack. This usually occurs when the actions involve hitting some api endpoints which require more than ‘some time’ to respond back. Any fix in the slack.py file or any other fix would be highly appreciated to counter this http_timeout error.

Can we run this version on M1 mac?

I am also having the same problem, after spending few months away from rasa, coming back is being hard has it is harder now just to install stuff, I really hope they find a way back to allow pip install on Rasa X

I am unable to install the latest version of rasa-x This is the error that i got - ERROR: Could not find a version that satisfies the requirement rasa-x==1.1.0 (from versions: 0.0.1, 0.20.0, 0.20.1, 0.20.2, 0.20.5) ERROR: No matching distribution found for rasa-x==1.1.0

Any assistance would be appreciated Thanks

Hi,

This still isn’t working for me. No matter how many times I’ve tried Rasa X won’t install on my device. I have rasa open source v–3.1

Am I following the wrong docs?

Desperately need help please! it’s for my final project which is due soon!!!

Thank you!!

Please create a new post with enough details to be able to know what you did, what you tried, what errors you got, and your setup.

Miss your youtube videos, hopefully, you are resting well in your new place. We need you back on youtube :slight_smile:

2 Likes

I got the same error message on Google Could, using the exact same rasa, rasa-sdk and rasa-x versions.

> /opt/venv/lib/python3.8/site-packages/rasa/cli/x.py:354: UserWarning: Your version of rasa '3.1.0' is currently not supported by Rasa X. Running rasa x CLI command with rasa version higher or equal to 3.0.0 will result in errors.

  • rasa: 3.1.0
  • rasa-sdk: 3.1.1
  • rasa-x: 1.1.0
2 Likes

@Johan1us can you tell what method did you used?

GKE or REI in VM?

Thanks!

@nonola In Google Cloud, I create a VM instance. There I deploy Rasa-X with the helm chart.

1 Like

@Johan1us thanks! I’ll give it a try.

Hey, @Johan1us did you manage to solve this issue? I am trying to run rasa X on Google cloud and it’s not working.

Hi @GiedreM, for now I went back to rasa 2. On google cloud I deployed the helm chart rasa-x/rasa-x --version "2.11.0". This will install rasa X 0.42.6 in combination with rasa 2.8.14 and rasa-sdk 2.8.3. If you do this you may also need to install an older version of kubernetes. Right now I have microk8s --classic --channel=1.20/stable installed

You probably also need an older version of scipy. I installed scipy 1.5.4 otherwise rasa x can’t work with the model.

1 Like

Thank you for the response. I hoped I can make it all work with the newest versions, as the bot was written using Rasa 3.0.

Hi @GiedreM, if you have a solution, please share it. Later I will look into it again, but right now time is my constraining factor. If I find a solution I will share it here too.

Rasa 3.1.0 has the following restricted dependency on numpy: numpy = “>=1.19.2,<1.20.0”

Installation is successful on Ubuntu 18.04 with python 3.9.10.

However, on M1 mac (arm64) it fails with:

Installing numpy (1.19.5): Failed
EnvCommandError

From python 3.x - numpy build fail in M1 Big sur 11.1 - Stack Overflow :

Since NumPy 1.21.0, it has released universal2 wheels for Python 3.8 and Python 3.9 on Mac. It becomes installable on Mac M1.

I’m guessing we will have to wait for Rasa to upgrade this dependency and possibly others.

Hello guys. I’m facing exactly the same issue. I’ve installed Rasa X on a fresh AWS machine running Ubuntu. After a lot of struggle to install Rasa X with the Ephemeral Installer and upgrade it to version 1.1.0 I’m getting the following warning and then errors when trying to have a conversation with the basic mood chatbot. By the way, this bot was trained using Rasa Open Source 3.1.0, which should be supported by Rasa X 1.1.0 according to the documentation.

Here’s the info about my Rasa X instance: image

Am I doing anything wrong? Please, any help would be appreciated.

Do you use a dockerfile for rasa container that installs spacy? I had to remove the installation of spacy ( that was messing up the versions of scipy and only kept the download of the model from spacy:

RUN python3 -m spacy download ro_core_news_sm

Hope it helps