Rasa listening ports + python broke Help

Hi, I am working on creating my very first rasa chatbot. I went through the masterclass and I was ready to run the following command for masterclass video #8.

rasa run actions & rasa shell

I got the following error:

OSError: [WinError 10048] Only one usage of each socket address (protocol/network address/port) is normally permitted

I google the error and found out that a recommendation to “kill the port” in where the problem was happening

I first used

netstat -ano|findstr 5055

5055 is the port of the error and where the webhook was connected. they suggested using the number value obtained to kill the listener to that port. so googling a little more I fond out how to do it, turn of the port

following the advice, I used the resmon in the cmd and find the listening port that was for 5055 that also said python on it.

Finally, I used this advice to kill the port that was not letting me run the rasa run actions

taskkill/pid 11704 /F

11704 was the number of the port for 5055.

after doing this I went back to the code to try to run rasa run actions and I found myself in a limbo


I tried to run a couple of python scripts and some of them never finish to execute. In a similar way as rasa run actions never finish executing some scripts are not working either. Also, none of the rasa’s commands finish executing.

Nothing seems to work. Please I really need help. I think it has something to do with TCP configuration that is something I do not know. Please help!

Things I tried:

  1. uninstall reinstall rasa, rasa-x, rasa-sdk
  2. uninstall reinstall anaconda
  3. uninstall reinstall python
  4. re-run rasa init
  5. used system restore for previous windows checkpoint. :frowning:


Welcome to the community! I’m sorry that you had to go through so much pain. A thing which you could try is to use different ports for your commands :thinking: