Unable to start server-error while attempting to bind on address ('0.0.0.0', 5005)

rasa run -m models --enable-api --cors “*” --debug

[2020-04-24 14:09:28 +0530] [17600] [ERROR] Unable to start server Traceback (most recent call last): File “C:\Users\mjeevaba\AppData\Roaming\Python\Python37\site-packages\sanic\server.py”, line 895, in serve http_server = loop.run_until_complete(server_coroutine) File “c:\programdata\anaconda3\lib\asyncio\base_events.py”, line 579, in run_until_complete return future.result() File “c:\programdata\anaconda3\lib\asyncio\base_events.py”, line 1374, in create_server % (sa, err.strerror.lower())) from None OSError: [Errno 10048] error while attempting to bind on address (‘0.0.0.0’, 5005): only one usage of each socket address (protocol/network address/port) is normally permitted

i think your port is aleady in use with some rasa command

1 Like

I faced the same issue. You can resolve this by killing the process running on 5005 port.

Steps to kill the process:

WINDOWS

  1. find the PID number by running:

netstat -ano | findstr :5005

  1. Enter PID number below to kill the process

taskkill /PID 5005 /F

MAC

  1. kill $(lsof -t -i:5005)

Source: cmd - How do I kill the process currently using a port on localhost in Windows? - Stack Overflow

4 Likes

Thanks. when i run this in command line --> netstat -ano | findstr :5005

C:\Users\mjeevaba>netstat -ano | findstr: 5005 ‘findstr:’ is not recognized as an internal or external command, operable program or batch file.

also failed taskkill /PID 5005 /F

although i can find the PID for port 0.0.0.0:5005 by running netstat -ano it was some number like 32145 changed the command taskkill /PID 32145/F

the ask got killed. thanks for resolution but why findstr was not working?

Glad I was of help.

Maybe this command would work:

netstat -a -n -o | find "123456"

I do not have windows installed so I cannot check it.

thanks, it worked. Need to capture the PID and kill it! Usually its because multiple RASA servers are running.