Rasa ignores config changes

Hi, I’m trying to change the pipeline configuration in Rasa X (replacing a duckling component with my own service) but the original duckling server is used nevertheless.

  • I tried to change the config in Rasa X
  • I tried to update the config via git
  • I retrained the model
  • I restarted and recreated all pods

What am I missing here?

Thank you for bringing it up Stefan.

Could you confirm if you’ve set your custom url in the “RASA_DUCKLING_HTTP_URL” environmental variable?

Optimally, you’d also turn off the native service in the rasa helmfile settings. Example:

duckling: 
enabled: false 

rasa: 
extraEnvs: 
- name: "RASA_DUCKLING_HTTP_URL" 
value: "[http://my-duckling.url](http://my-duckling.url/)"

Thank you @erohmensing for the information.

thanks a lot … that was the “problem” :smiley:

1 Like