Config and NLU pipeline in RasaX

Hello, I am using RasaX 0.19.5 with Rasa 1.1.4 running on docker. On GUI of RasaX i can not see config tab. What to do if i want to change the Rasa NLU pipeline or change the language. I even cant see nlu config file on server side mounted to some docker volume. What to do if i want to change the pipelne.

Regards Feroze

1 Like

I am still waiting for response. Anybody here can respond please

I am still waiting for the response. I need it urgently. Can anybody answer please its taking too long.

Hi there @feroze.chaudhry. Please be patient with us, we get loads of new questions on the forum every day, which come on top of our regular jobs working on the product to make it better for the community!

I even cant see nlu config file on server side mounted to some docker volume.

You’re saying in your rasa-production container, you can’t see the config.yml? Are you sure there is a config in the location that you mounted to the container?

I mounted the config file in the rasa-production container but it is not using that config file. It is using some default configuration.


There used to be configuration option in the older version of Rasa X

In 0.19.5 it is removed and there is no option on server where we can specify the configuration as rasa x command doesn’t have any flag to specify configuration file


Hm that is strange that the config tag disappeared. It might be something we’ve fixed since – can you try upgrading to 0.20.1?

When you’re in deployed (not local) mode, I’m pretty sure the config is picked by the model in production, it’s not pulled from the volumes. Are you sure that the model configuration is incorrect?

It is now showing. I did nothing not even changed the version of RasaX i just logged in today and saw the configuration tab is showing now. May be you guys fixed it.

Can’t be that we fixed it if you didn’t update :smiley: if something like this happens again, logging out and back in is always a good first step! It’s like turning it off and back on again.

@erohmensing, I’m having the same error here. The installed versions of my rasa is 1.2.9 and my rasa-x is 0.20.3. I tried to logg out and back but the error continues.

@augusto.peterlevitz can you try with the latest versions of Rasa X and Rasa? Is yours also running in Docker?