RASA_HOME env variable

I’ve installed version 0.19.5 on a couple of systems using the server deploy instructions and the installation is not picking up my RASA_HOME setting as the install dir. The release notes for 0.19.3 state that this should work.

Has anyone else found RASA_HOME to work with the server deployment method?

Hi @stephens, how are you setting the RASA_HOME variable before installing? Would you mind trying this again with 0.20 which was released a few days ago?

I’m running under the bash shell on Ubuntu 16.04.

export RASA_HOME=/home/rasa
curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/stable/install.sh
sudo bash ./install.sh

I’ll give the new release a try.

@stephens since you’re running as sudo the existing env var won’t be propagated into the command. You need to run sudo with the -E flag, i.e.

export RASA_HOME=/home/rasa
curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/stable/install.sh
sudo -E bash ./install.sh

@ricwo thanks for the solution.

Just a quick note that in the current tutorial Docker-Compose Quick Install there is a small confusion in the command (it’s sudo bash -E ./install.sh instead of sudo -E bash ./install.sh). It might seem quite trivial but someone could spend a lot of time figuring out why the first command does not work and where that rasa x installation folder actually is.

Thanks for reporting this. A PR has been submitted.