Rasa First Tutorial Error

This is the error (env) C:\Users\Maheeka\Desktop\chatbot>rasa init --no-prompt Traceback (most recent call last): File “C:\Users\Maheeka\AppData\Local\Programs\Python\Python35\Lib\runpy.py”, line 193, in run_module_as_main “main”, mod_spec) File “C:\Users\Maheeka\AppData\Local\Programs\Python\Python35\Lib\runpy.py”, line 85, in run_code exec(code, run_globals) File "C:\Users\Maheeka\Desktop\chatbot\env\Scripts\rasa.exe_main.py", line 4, in File "c:\users\maheeka\desktop\chatbot\env\lib\site-packages\rasa_init.py", line 8, in from rasa.run import run File “c:\users\maheeka\desktop\chatbot\env\lib\site-packages\rasa\run.py”, line 7, in from rasa.core.lock_store import LockStore File “c:\users\maheeka\desktop\chatbot\env\lib\site-packages\rasa\core\lock_store.py”, line 10, in from rasa.core.lock import TicketLock, NO_TICKET_ISSUED File “c:\users\maheeka\desktop\chatbot\env\lib\site-packages\rasa\core\lock.py”, line 4, in from typing import Text, Optional, Union, Deque, Dict, Any ImportError: cannot import name ‘Deque’

I’m completely new to Rasa. Can anybody help?

Try installing rasa on anaconda and creating rasa setup using it.

1 Like

Hi @Maheeka,

according to this documentation, Deque is new from python 3.5.4 upwards.


Let’s me assume that you maybe should check your python version regarding that!?

Regards Julian

1 Like

I’ve changed python version to 3.6 and it didn’t work. same error appears.

hey @ashishPatel Thank you. It worked!!!


How did it work?