RASA Core Train Stuck

Hi everyone,

Have anyone faced issue with rasa.core.train ? I tried to train core, and it’s not large stories, but i used extensive checkpoints there. When i train it on AWS ec2 t2.2xlarge instance with jupyter notebook and with this code:

from rasa.core import train
from rasa.core.agent import Agent
from rasa.core.policies.fallback import FallbackPolicy
from rasa.core.policies.keras_policy import KerasPolicy
from rasa.core.policies.mapping_policy import MappingPolicy
from rasa.core.policies.form_policy import FormPolicy
from rasa.core.policies.memoization import MemoizationPolicy
user_policies = [MemoizationPolicy(),MappingPolicy(),KerasPolicy(epochs=55, max_history=15), FormPolicy(),FallbackPolicy(nlu_threshold=0.65)]
a = Agent('data/domain.yml', user_policies)
story = await a.load_data('data/dialogue/', augmentation_factor=0)

Is this code deprecated? Can someone help me with this? Thanks

It might be the case that something has gone wrong in your checkpoints, you can check the validity of your stories using rasa test.

Hi @imLew,

So i tried on my local machine, and it’s working, maybe it’s the AWS setup. I used t2.2xlarge but stuck, but my local machine only use core i7 with 16 gb rams, and working just find.

Yes, if the same code runs fine on your local machine then it has to be an issue with AWS.