Rasa bot integration with Facebook Messenger

Hello, I am an intern working on an already developed Rasa chatbot. My internship deliverable is to integrate the chatbot on FB messenger. However, I am not able to create a webhook for the same. Attaching a copy of the error image. Any help on this would be appreciated

@Juste @erohmensing

  1. Which port number you are using in ngrok ?(default 5005)
  2. After running the project (rasa run) ,then try to connect fb using webhook
  3. FB page admin only do this
  4. Change the verify token

Yes 5005 is the port that I’m using, also I am not able to execute rasa run command, I am just running my chatbot using “npm start”. What do you suggest? If I run the command “rasa run” it gives me an error

HI @RenuDighe. Could you share the log of the error you get when you run the rasa run command? Also, what would help is if you could share the message you see on ngrok once the facebook tries to validate the URL.

Actually, I think it is because, Facebook is not able to verify that your “webhook handler”(Rasa facebook webhook endpoint) is working. So to help you as other suggest, you need to give I think the error that you get from rasa run.

This is what I get when I click on Save and Verify on FB Developers Page

And this is what I get when I run rasa with the credentials file

I usually run the bot using “npm start”

In which port are you running the rasa serveur whe using ‘npm start’; If you run on the port “5005”, you should run “./ngrok http 5005”. Because, what I see is that you are using the port 80 on ngrok. Hope this help

Screenshot is of port 80, but I have tried doing the same for 5005, 5004 and 5055. My chatbot is using 5055. But does not work for it either

Do you have model folder or not ? in your project.If you don’t have please train your project with (rasa train)

Which version of rasa are you using ?

I have the models folder and running ‘rasa train’ command gives this error


@RenuDighe what’s the version? rasa train wasn’t a command until rasa 1.0.0. Are you still on rasa_core and rasa_nlu?

Yes I am using rasa_core and rasa_nlu. What should be done to migrate to rasa 1.0.0?

1 Like

There is a migration guide here :slight_smile: since your versions are so old you might also need to checkout the older migration guides too here

Thanks a lot :slight_smile:

Sure thing! Hope the migration goes well, then let us know if you still have trouble with facebook :slight_smile:

Sure :+1:t2:

I am confused a little. My rasa installation folder shows rasa, rasa_core and rasa_nlu all three. How should I proceed?