Rasa Anaconda installation issues

Hi, I am trying to run rasa through anaconda as soon as type any rasa command syntax…it thows a bunch of errors saying

  • anaconda3\envs\rasa_new_crt\lib\runpy.py", line 192, in _run_module_as_main,
  • \anaconda3\envs\rasa_new_crt\lib\runpy.py", line 85, in _run_code exec(code, run_globals)
  • anaconda3\envs\rasa_new_crt\lib\site-packages\rasa_main_.py", line 14, in from rasa.cli import (
  • anaconda3\envs\rasa_new_crt\lib\site-packages\rasa\core\utils.py", line 25, in from sanic.views import CompositionView ImportError: cannot import name ‘CompositionView’ from ‘sanic.views’

could anyone help me out here?

Hello and Welcome to Forum @ab-star! Please downgrade the sanic version and then run the rasa and can you please share the rasa --version?

Thank you Nimit for your response…could i know which sanic version i need to downgrade? and all the rasa commands are giving me the same error in anaconda prompt

@ab-star please share me the sanic version you have then I can suggest you well for me I’m using sanic==21.6.0 but I can thrown other dependencies as well, depends on the which rasa version you are trying to install i.e 2.x or 3.x.

@ab-star I’d also recommend to please see this video and then try to proceed for other solutions: Installing Rasa Open Source 3.x: Windows 10 (64 bit) - YouTube

@ab-star I hope you create the conda base environment for python 3.7 and 3.8 not on python 3.9 as rasa yet not supporting for 3.9.

Good Luck!

Hey Nimit…This is my Sanic version currently Sanic 21.12.0; Routing 0.7.2…also i followed the video you suggested but at last it ran into same issues…i am using python=3.8

@ab-star I will recommend to start the fresh process.

Yes Nimit…i tried uninstalling anaconda and did a fresh start again with the following steps…but no luck …any idea or steps you can recommend please

@ab-star strange, can you install rasa and rasa-sdk to 2.8.2?