Problem in publishing rasa bot in a web page on local host

Hi, I tried to integrate my simple chatbot on a webpage on local host. I added a widget in html file for integration of chatbot. The html file is given below:

Then i run rasa core with command: rasa run --cors “*” --debug After running above command the following msg was shown: In the message it is clearly shown that rasa server is up and running. and an error message related to socketio version. but after running html file no widget is reflected on the page. the screen shot is given below: I have used credentials as instructed in rasa master class: I am not able to understand why widget in html not working. please help. I am using following versions of packages in windows 10: rasa 2.1.2 rasa-sdk 2.5.0 rasa-x 0.38.1 python-socketio- 4.6.1 I had trained and checked my bot earlier using rasa shell. please anybody help to resolve the issue and also version related issue of socketio.

@singhvinay1987 is this your issue solved?

yes,this was python-socket io and python-engine io version compatibility issue. I used python-socket in version 4.6.1 and engineio version 3.13.2 for rasa 2.5.x.

@singhvinay1987 please close this thread with a solution. Good luck!