Problem integrating rasa-webchat widget to my webpage


So basically I’m trying to integrate rasa chatbot widget from here: GitHub - botfront/rasa-webchat: A feature-rich chat widget for Rasa and Botfront as it has many reviews and features. I’m integrating it on a completely empty webpage.

What I have done so far - ran Rasa chatbot, setup Ngrok server so that I can access index.html which is on Linux server along with whole Rasa project from anywhere using Ngrok link and imported that url as socketUrl in index.html

The problem is that after I insert code from the provided git project and open my webpage, in the console I see this error:

Error: server error at u.onPacket (index.js:116) at e.exports. (index.js:116) at e.exports.r.emit (index.js:1) at e.exports.onPacket (index.js:12) at index.js:17 at Array.forEach () at e.exports.onData (index.js:17) at f. (index.js:116) at f.r.emit (index.js:1) at f.onData (index.js:116)

The index.js of course is not under my control since I can see it is uploaded from

And I’m pretty sure that the issue is not on my Linux server side since I managed to setup a simple unknown widget using code that I found online some time ago, but it does not satisfy me.

Any ideas what went go wrong here? I saw tutorials of that chat widget, many peoples are using it and it is most popular on search engines, so it’s hard to believe that their server is having issues.

@Benten What you basically want to archive, do you have RASA project ready? Do you want to deploy on website like WordPress? or do you want to run rasa project on localhost whilst using rasa-webchat widget?

For now I want to test the bot on localhost using rasa-webchat. Later on I will deploy it to the product website.

Hope this will help you Rasa Webchat Integration - #119 by Horizon733 If you need help in deployment on website let me know.

1 Like

@Benten I hope you fine?

@nik202 Thanks, I switched from rasa-webchat to another GUI option I found online and its working fine so far.

@Benten Can you please share which GUI you are using instead of rasa-webchat(botfront). Thanks.

Currently I’m using this one: GitHub - JiteshGaikwad/Chatbot-Widget

Had no problem connecting it with Rasa Open Source server, but struggling with Rasa X (installed using kubernetes) implementation.

Hey! @Benten It’s fine you used rasa-webchat(bot front) or above mention repo code. But, this repo code will not able to deal with the dynamic nature of the website. I tried both, even the third chatroom also. But then I stick to rasawebchat which is far far better than any other, I am not saying another repo is bad or not useful. But, botfront fit my requirements.

@Benten Your issue with rasa webchat is you not updated the version from 1.x.x to 1.0.1 whilst using in index.html or directly using in body of website. If you still able to follow the video I share you can see where you went wrong.

Good Luck!!

I have tried changing version from 1.x.x to 1.0.1 or 1.0.0, it’s always the same response in the console. I will try again after I manage to post a request to RasaX which is running in Kubernetes cluster.