No features present. You are using an empty spaCy model


if I use the rasa shell in debug mode I get the following message: 2021-01-19 22:47:31 DEBUG rasa.nlu.featurizers.dense_featurizer.spacy_featurizer - No features present. You are using an empty spaCy model.

what does this message mean? Is my spaCy model loaded correctly?

I use the following pipeline to train the model:

Screenshot 2021-01-19 235602

@wordman2 try the the below it might help you:

pip3 install rasa[spacy]
python3 -m spacy download en_core_web_md
python3 -m spacy link en_core_web_md en

how do I do it if I’m using rasa on docker? I’m very new to docker

Rasa’s documentation says

The {version}-full tag includes all possible pipeline dependencies, allowing you to change your config.yml as you like without worrying about missing dependencies.

I use the full rasa image as you can see right here:

I can load the model and it works but the message described above is still displayed. The linking seems to be fine:

2021-01-21 11:47:39 INFO     rasa.nlu.components  - Added 'SpacyNLP' to component cache. Key 'SpacyNLP-de'.

@wordman2 try adding the following lines in your docker file:

RUN python -m spacy download es_core_news_sm &&
python -m spacy link es_core_news_sm es

Please check the below:

spacy-nlp-docker/Dockerfile at master · pasupulaphani/spacy-nlp-docker · GitHub \

I hope it can help you

I tried but the debug message still remains.

It’s also interesting after this message, there’s another debug message saying “there is no trained model for ResponseSelector” (see below) even in the domain.yml there are enough training data

@koaning hi, could you please help here? I have the same 2 issues when I run rasa shell. What do these warnings mean and how can I fix it? TIA

For more details: I have included the spacy language model in config.yml. it has also been downloaded in my venv, where I am running the rasa shell.