My version of rasa does not match Udemy Course Version - Is this a problem?


I have started taking the Udemy certification course thanks to @stephens recommendation on a different thread.

(Here’s the link to the course have to me:

I am following the instructions in the first video exactly.

She says that we must have these versions of rasa:

rasa version 2.1.3 rasa sdk version 2.1.2

However, after following her instructions for pip installing rasa I find I have this version:

rasa --version rasa --version Rasa Version : 2.8.9 Minimum Compatible Version: 2.8.9 Rasa SDK Version : 2.8.2 Rasa X Version : None Python Version : 3.8.2 Operating System : macOS-10.15.7-x86_64-i386-64bit

Is this going to be a problem?

As long as it’s 2.x, there are no major differences and you can follow the courses.

You can check out the Change Log to see what the differences are since 2.1, but again, you can continue the course without worries.

1 Like

You can install Rasa with previous version easily with command

pip3 install rasa==2.1.3
pip3 install rasa.sdk==2.1.2

1 Like

Hey Chris,

My version of Rasa is beyond 3.0 (latest) and it does not accept md file, hence unable to train nlu. Can u please help on converting the file to yaml. Can anybody share the complete syntax? I tried rasa dataconvert syntax which was there in rasaforum but the error states, “invalid nlu data”.