It is too slow too reply when I run in location pc

This is my first question maybe I say not good , but it will be better .ok now I will say my question. when I run my project on my notebook computer (CPU I7 8750H GTX 1060 RAM 32G) if the answer need to predict it will be slow in action . I found the same [question](https://forum.rasa.com/t/rasa-nlu- slow-response-on-localhost-machine/10254) but I don’t think it can help me . I found some is slowly such as

processor.py 91

      processor.py 91
       wupj_start_time = t.time()
        await self._predict_and_execute_next_action(message, tracker)
        print("processor_91 cot:", (t.time() - wupj_start_time))

action.py 402

 wupj_start_time = t.time()
            response = await self.action_endpoint.request(
                json=json_body, method="post", timeout=DEFAULT_REQUEST_TIMEOUT
            )
            print("self.action_endpoint.request(action402) cost:", (t.time() - wupj_start_time))
            wupj_start_time = t.time()
            should_predict_another_action = await self._run_action(
                action, tracker, message.output_channel, self.nlg, policy, confidence
            )
            print("368-->", action)
            print("processor_362:_run_action:", (t.time() - wupj_start_time))
           but I also print time in my actions but  my action not need much time

can any one give me some suggests. what is wrong with me and how can I do .

Hi @BigDuck. It’s a great question :slight_smile: To try and help you I would need to know which Rasa version are you running and how much training data do you have for NLU and dialogue models?

thank you for your answer .my rasa version is 1.1.8 and my model(core+nlu) only 2.1M .

Hmm, that shouldn’t cause too much trouble. Do you have any custom actions that might take the long time to execute - some backend integrations (api calls, etc)?

I have my actions but I print the time and it 's only cost less than 0.5s.

Do you think you could share the project with me so I can replicate? If it something you don’t want to share here, you can shoot me an email at juste@rasa.com

ok no problem ,I will send my project to you in my free .if there are something wrong or unreasonable please help me point out. It’s my 'hello world ’ with rasa . thank you very much

Hey, did you guys figure out what the problem was? I am facing pretty much the same problem and would love to know what the solution was

I figured it out for my case. I am running it on a Debian server and all I had to do was change the endpoint configuration in the endpoints.yml from “http://localhost:5055/webhook” to the server’s local ip address. Still a bit baffled though because it worked on the local environment and also on the Debian virtual machine without having to change it.

1 Like