Issues with Botfront Development

Botfront Development is not working. RASA instance not reachable. Train button is disabled.

I’m trying to install **botfront 1.0.**5 in my local machine (Ubuntu 18.04) using botfront source code(Development), following the exact instructions in this page https://github.com/botfront/botfront.

So I ran all the above said commands, but I am getting the error :

Rasa instance not reachable and my Train Button is also not enabled.

I am sharing my screen shots below :

Note : I have set the project-id also using botfront set-project <project_id> and have cross checked also inside botfront.yml

These are my Project Settings.

I have also tried replacing my localhost with my machine IP address, but still getting the same error. Then I have changed the db config from bf-os to bf under package.json file.

“start:docker-compose.dev”: “MODE=development BF_PROJECT_ID=bf MONGO_URL=mongodb://localhost:27017/bf meteor run”

When I am running botfront up (complete botfront service) inside my project folder, and running meteor npm run start:docker-compose.dev inside my source code folder, I can see the Train Button is enabled but it is fluctuating again and again (enabling / disabling) and I can train the project successfully.

But I am facing another problem here, i.e. after completion of training, when I am testing the chatbot, it is showing me its utterance_id rather than its original message content.

And below is my Server Side log screen shot.

Please help me to find the solution so that I can successfully run the project from the source code and can deploy it.

You can find here the complete Problem Statement.Problem Statement and Screenshots