Is it possible to slet a slot in one action then call it with tracker and use it in another action?

hi ! so i set a slot “type” in one action and it’s submitted perfectly, now when i’m calling it in another actions, it’s giving me back the last slot the i set ! image image can somebody help me ?

@nik202 can u plz help me again? thank u

@rahma Sure! You need to reset as blank all slots for other query!

@nik202 in fact, i’m not going to ask the user to enter it again, i want to call the slot already entered by the user , i asked the user to choose a type, either “auction” or “call for tender” then asked him to choose a location, i made the action where i submitted those two slots and they are well set . now after they have been set , i need to use them in another action, that’s why i’m calling them with tracker, the slot “location” is called with right value , but the slot “type” is called with the value of the slot “location” !!

@rahma need to see file then.

What I understand, you need to take two value of input for your slot and then give those values to other slots? For other process. Right

@nik202 you should know it was working fine yesterday, i just wanted to add one another slot and it stopped performing as before, even when i deleted the new slot. this is my action,

this is the rules, during the conversation ,slots are well set and they are returned correctly, the issue is when i want to reuse them in “action_search” , image the first slot “types” is supposed to return “call for tender” as it does through the conversation. hope this clearifies things for you haha

@rahma Honestly, I’m trying to see what is going on but, I guess its still not the complete code. Even your output screen, I can’t find your choice is: etc etc. I think you need to check the code again, try print the values at ever steps in action file and see what value it is returning, or even check the story/rules. Hope you mention all the actions in domain.yml files?

@nik202 yes it’s just missing two actions, the ones setting the type and location slots image image

@nik202 the issue is that the slots are well fit and submitted but when i call them in another process ,the action “action_search” both are returning the same value, which is the value of the location slot

@nik202 when i print the values at each step it returns the right values, then when i call it in other action it does not

@rahma share and stories.yml please.

@nik202 there it is (5.2 KB) rules.yml (1.8 KB)

@rahma Where this come?

on line 125?

                    typ="Vente aux enchères"
                elif(types== "call for tender"):
                    typ="Appel d'offre"

Why only type where is location in actions_search?

@nik202 yea because the type in my data is in french so i translated in, there is a condition about both right after that , i tried the action_search as a python function where i set manually the types and locations and it workes perfectly so there is nothing wrong about it , the issue is with rasa slots as much as i think

@nik202 , what do u mean ?

@rahma If you code is perfect, delete the old models, re-train again and do let me know again. @rahma If still the issue, and you believe your code is perfect then check the rule. submit and action_search one.

@nik202 i’m okey with meet, i would like to have some help ! thank u

@nik202 (10.6 KB)