Interactive training exception=AttributeError("'MultiDiGraph' object has no attribute 'node'")

I tried interactive leaning in Rasa 1.3.9. I got following exception 2019-10-22 17:07:17 ERROR - An exception occurred while recording messages. Traceback (most recent call last): File “/d/aroha/my360_bot/venv/lib/python3.7/site-packages/rasa/core/training/”, line 1385, in record_messages await _plot_trackers(sender_ids, plot_file, endpoint) File “/d/aroha/my360_bot/venv/lib/python3.7/site-packages/rasa/core/training/”, line 1319, in _plot_trackers event_sequences[-1], event_sequences, output_file=None, max_history=2 File “/d/aroha/my360_bot/venv/lib/python3.7/site-packages/rasa/core/training/”, line 491, in visualize_neighborhood _merge_equivalent_nodes(graph, max_history) File “/d/aroha/my360_bot/venv/lib/python3.7/site-packages/rasa/core/training/”, line 207, in _merge_equivalent_nodes graph, i, j, max_history File “/d/aroha/my360_bot/venv/lib/python3.7/site-packages/rasa/core/training/”, line 147, in _nodes_are_equivalent return graph.node[node_a][“label”] == graph.node[node_b][“label”] and ( AttributeError: ‘MultiDiGraph’ object has no attribute ‘node’ 2019-10-22 17:07:17 ERROR asyncio - Task exception was never retrieved future: <Task finished coro=<_serve_application..run_interactive_io() done, defined at /d/aroha/my360_bot/venv/lib/python3.7/site-packages/rasa/core/training/> exception=AttributeError("‘MultiDiGraph’ object has no attribute ‘node’")> Traceback (most recent call last):

1 Like

Something change with one of the libraries. You can call rasa interactive with the option --skip-visualization or if you need to see the nodes, try an older version.

@Gehova Can you give some more information on what command did you use to start interactive learning and at what stage did this occur?

rasa interactive --skip-visualization working Thanks

Facing the same with rasa visualise command.

Fixed by replacing “graph.node” with “graph.nodes” on (based on networkx version 1.x to 2.0 migration guide Migration guide from 1.X to 2.0 — NetworkX 2.5rc1.dev20191024222630 documentation)


That worked like a charm! Thanks!

Hey everyone, this was a dependency issue that should be fixed on rasa 1.4.2 :slight_smile:

Thanks Working

Thanks - I installed 1.4.2, but not able to get the webpage working

Traceback (most recent call last): File “c:\angshuman\rasa-1.4.2\venv\lib\site-packages\sanic\”, line 918, in handle_request handler, args, kwargs, uri = self.router.get(request) File “c:\angshuman\rasa-1.4.2\venv\lib\site-packages\sanic\”, line 407, in get return self._get(request.path, request.method, “”) File “c:\angshuman\rasa-1.4.2\venv\lib\site-packages\sanic\”, line 470, in _get raise NotFound(“Requested URL {} not found”.format(url)) sanic.exceptions.NotFound: Requested URL /visualization.html not found