Interactive Learning in rasa_core0.12.0

Hi, I am facing issue when I run interactive training. My code is this;

    import logging

    from rasa_core import utils, train
    from import interactive

    logger = logging.getLogger(__name__)

    def train_agent():
        return train.train_dialogue_model(domain_file="domain.yml",
                                          policy_config = "config_nlu.yml",
                                          kwargs={"batch_size": 50,
                                                  "epochs": 200,
                                                  "max_training_samples": 300

    if __name__ == '__main__':
        agent = train_agent()
        interactive.run_interactive_learning(agent, stories="data/")    

when it executed it shows the following output:

Can anyone help me to get rid of this?

You should update rasa_core to 0.12.1, there was a bug with the interactive learning that they’ve fixed.

Even after update I got the same error.


@abhishakskilrock Can you please tell how you resolved the error? I am getting the same error. But I added policy_config line and it was kind of working. But I now get an Internal Server error 500 after I enter any input. Can you please tell me how you resolved this issue? Thanks

@Arunkumar0258 run this command it will work: python -m rasa_core.train interactive -o models/dialogue -d domain_form.yml -s data/ --nlu models/default/nlu --endpoints endpoints.yml

@abhishakskilrock I know that command works, but I want to make a Python script that does that exact thing. Btw I got the answer, I changed my code a bit and now it works. Thanks anyways :slight_smile:

@abhishakskilrock Hey if you want to run the file you ran first just try to import these files as well.

from future import absolute_import

from future import division

from future import print_function

from future import unicode_literals

Thanx @Akshit for helping me out but I have already import those libraries and Issue was not there issue was with calling stories with agent. We have to call stories file when we are calling agent

Hey @Arunkumar0258 did you got data in file?
Actually I didn’t get any data in I got blank file.

@abhishakskilrock Yes I have the data in file. I put it there myself, it’s were I put my intents. I have another file where I store my stories for all the intents.