How to enable interactive learning

Hi everyone!

I am completely new with Rasa and I tried to explore features a bit. Have in mind that I am completely new to Python as well (I am an experienced javascript developer if it is of any help).

I have ran into an issue, while building a very simple bot. The bot consists of a domain.yml file and a few stories, all taken from the official tutorial.

I can train the bot by running this: python -m rasa_core.train -d domain.yml -s stories.md -o models/dialogue

I can run the bot by running this: python -m rasa_core.run -d models/dialogue

Everything is alright so far.

When I try interactive learning, I get this:

$ python -m rasa_core.run \
            --interactive -d models/dialogue \
            --stories-out stories_interactive.md
/home/mariosant/anaconda3/lib/python3.6/site-packages/h5py/__init__.py:36: FutureWarning: Conversion of the second argument of issubdtype from `float` to `np.floating` is deprecated. In future, it will be treated as `np.float64 == np.dtype(float).type`.
  from ._conv import register_converters as _register_converters
:0: UserWarning: You do not have a working installation of the service_identity module: 'No module named 'service_identity''.  Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.  Without the service_identity module, Twisted can perform only rudimentary TLS client hostname verification.  Many valid certificate/hostname mappings may be rejected.
usage: run.py [-h] -d CORE [-u NLU] [-p PORT] [--auth_token AUTH_TOKEN]
              [--cors [CORS [CORS ...]]] [-o LOG_FILE]
              [--credentials CREDENTIALS] [--endpoints ENDPOINTS]
              [-c {cmdline,facebook,slack,telegram,mattermost,twilio,rasa,botframework,rocketchat,callback,rest}]
              [--enable_api] [-v] [-vv] [--quiet]
run.py: error: unrecognized arguments: --interactive --stories-out stories_interactive.md

Any help to get it running, would be highly appreciated!

Some info about my setup:

$ python --version
Python 3.6.5 :: Anaconda, Inc.

Never mind, I found this one:

1 Like

I tried this one but no luck though, it only started the action server. If I use the second command in another terminal window, it shows: OSError: [Errno 48] Address already in use: ('0.0.0.0', 5005)

python -m rasa_core_sdk.endpoint --actions actions&

python -m rasa_core.train \
  --online -o models/dialogue \
  -d domain.yml -s data/stories.md \
  --endpoints endpoints.yml
1 Like

run command kill $(lsof -t -i :5055) to kill the process which is using port 5055.

1 Like