Integrated version control::Not connect

i am using centos 7 i have installed rasa-x on server but when i use integrated version control and follow all the command i face issue

i use this in command curl --request POST --url --header ‘content-type: application/json’ --data-binary @repository.json

then it asks me for github username and password after that it return this


I already created deploy key![Capture|512x500]

when i manually try integrate it shows this


but still not connect

Hi Vaseem,

The Rasa X git integration was recently enhanced so that it is much easier. You no longer have to generate a key. The updated instructions are here.

From the Rasa X UI, select the button to connect to a repository then copy the generated key and add it to your git repo. Make sure to enable write access when you add the key.


i tried when i click on connect to repository a window popup shows u are connected to the repository: ** but in the status bottom left hand corner it says you are not connected an error shows in terminal

Exception occurred while handling uri: 'http://localhost:5002/api/projects/default/git_repositories/1/status'
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/sanic/", line 976, in handle_request
    response = await response
  File "/usr/local/lib/python3.6/site-packages/rasax/community/api/", line 205, in decorated_function
    return await await_and_return_response(args, kwargs, request)
  File "/usr/local/lib/python3.6/site-packages/rasax/community/api/", line 135, in await_and_return_response
    response = await response
  File "/usr/local/lib/python3.6/site-packages/rasax/community/api/blueprints/", line 152, in get_repository_status
    repository_status = git_service.get_repository_status()
  File "/usr/local/lib/python3.6/site-packages/rasax/community/services/integrated_version_control/", line 741, in get_repository_status
    is_remote_ahead = self.is_remote_branch_ahead()
  File "/usr/local/lib/python3.6/site-packages/rasax/community/services/integrated_version_control/", line 558, in is_remote_branch_ahead
  File "/usr/local/lib/python3.6/site-packages/rasax/community/services/integrated_version_control/", line 146, in _fetch
AttributeError: 'NoneType' object has no attribute 'git'

Looks like Rasa X is having a problem connecting to your git repo. I would disconnect the repo and start over using the latest instructions and latest Rasa X release.

i did. I recreate git repo install ubuntu 18.04 install latest version of rasa x and still throwing the same error. ??? what do i do

issue solved i have been using the wrong commnad

Could you share your solution? I have same issue with connecting a repo via Rasa X UI…

UPDATE: I’ve found that such error happens when rasa-x runs in “local mode”. Unfortunately rasa team removed appropriate LOCAL_MODE variable from their official docker composes (starting from version 0.28.x) and “forgot” mention how to deal with it…

The Button of GitHub Integration in Rasa-X UI it doesn’t appear For me , I have installed Rasa x from pip install … ? what is the problem !!!