Installing error

ERROR: Command errored out with exit status 1: command: ‘y:\pythonproject1\venv\scripts\python.exe’ -c ‘import sys, setuptools, tokenize; sys .argv[0] = ‘"’"‘C:\Users\Bony Srivastava\AppData\Local\Temp\pip-install-29f4k8wg\rasa-core_9 53a3c5935fe4f998344ef4dcc81aadd\’"’"’; file=’"’"‘C:\Users\Bony Srivastava\AppData\ Local\Temp\pip-install-29f4k8wg\rasa-core_953a3c5935fe4f998344ef4dcc81aadd\’"’"’;f=geta ttr(tokenize, ‘"’"‘open’"’"’, open)(file);’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f .close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ egg_info --egg-base ‘C:\Users\Bony Srivasta va\AppData\Local\Temp\pip-pip-egg-info-hvzq00_u’ cwd: C:\Users\Bony Srivastava\AppData\Local\Temp\pip-install-29f4k8wg\rasa-core_953a3c5935 fe4f998344ef4dcc81aadd\ Complete output (14 lines): Traceback (most recent call last): File “C:\Users\Bony Srivastava\AppData\Local\Temp\pip-install-29f4k8wg\rasa-core_953a3c5935fe 4f998344ef4dcc81aadd[](YouTube)”, line 9, in import pypandoc ModuleNotFoundError: No module named ‘pypandoc’ During handling of the above exception, another exception occurred: Traceback (most recent call last): File “”, line 1, in File “C:\Users\Bony Srivastava\AppData\Local\Temp\pip-install-29f4k8wg\rasa-core_953a3c5935fe 4f998344ef4dcc81aadd[](YouTube)”, line 12, in readme = open(‘’).read() File “C:\Users\Bony Srivastava\AppData\Local\Programs\Python\Python38-32\lib\encodings\cp1252 .py”, line 23, in decode return codecs.charmap_decode(input,self.errors,decoding_table)[0] UnicodeDecodeError: ‘charmap’ codec can’t decode byte 0x9d in position 882: character maps to < undefined> ---------------------------------------- ERROR: Command errored out with exit status 1: python egg_info Check the logs for full com mand output.

Hi @bony05,

You seem to be experiencing the same issue referenced here: ModuleNotFoundError: No module named 'pypandoc' · Issue #1872 · RasaHQ/rasa · GitHub

That issue was closed a couple years ago, but may have popped back up. Can you please share the steps you took to install Rasa?

The forum uses markdown to render posts. To show code blocks in markdown you can wrap the code in three back ticks ```. For reference: Creating and highlighting code blocks - GitHub Docs

Hello, I got the same error too. My OS is Windows 10 and python version is3.9.0 i tried to install in Command prompt with “pip3 install rasa” and encountered with this error.

Please resolve,


Had the same issue (using new environment using Conda). The problem is often the latest version of python. Setting the version to 3.8 in stead of latest 3.9 solves the problem.

1 Like

I am also getting the same error in Rasa installation for Windows 32-bit python installation. I use VS code + Git Bash Terminal where I activated conda and created a virtual environment for python 3. so it is (rasaenv) with python 3.7.9… how to get rid of this pypandoc and charmap error? I tried later python versions and they also gave the same error. now I still get the error although some people mentioned that downgrading to 3.7 would solve the issue.