ImportError: cannot import name 'online'

Hi I am configuring online training… I am using the lastest version of rasa nlu(13.7) and core(12.7)

I actually copy the code of online training from latest full code. And When I run python, I got this error: ImportError: cannot import name ‘online’

BTW, this is from Weather bot tutorial.

Hey @Neptune. The weatherbot tutorial is not yet updated for the Rasa Core v0.12 and that’s why it was complaining about ‘online’ parameter for interactive learning. I’ll let you know once I upgrade the repo for v0.12 :slight_smile:

OK, thanks for letting me know! Suffering a lot from version issue.

@Neptune I have just updated the weatherbot repo so things should work now. :slight_smile: I’ll see what we can do to make the switching between versions less painful in the future.

Hi @Juste Please can I get the repo of the tutorial is it this one: ?

Thank you

I’am trying to do the online training but with the new version of rasa_core the ConsoleInputChannel don’t work, I tried to do online.run_online_learning(agent) but it said cannot import name ‘online’. Need an example for that please

I have the same issue. I’m using rasav0.12, should I upgrade it to something else or get rid of online ?

Okay I solved the error using interactive. I’m using rasa-core v0.12.

For information : It’s tricky to install with numpy library conflict between tensorflow and SpaCy you have to do it in a specific order

@Juste this is the error i’m getting could you help me with this? During or exception occurred while recording messages. Traceback (most recent call last): File “C:\Users\MS066115\AppData\Local\Continuum\anaconda3\lib\site-packages\rasa_core\training\”, line 1276, in record_messages _plot_trackers(sender_ids, plot_file, endpoint) File “C:\Users\MS066115\AppData\Local\Continuum\anaconda3\lib\site-packages\rasa_core\training\”, line 1220, in _plot_trackers max_history=2) File “C:\Users\MS066115\AppData\Local\Continuum\anaconda3\lib\site-packages\rasa_core\training\”, line 453, in visualize_neighborhood _merge_equivalent_nodes(graph, max_history) File “C:\Users\MS066115\AppData\Local\Continuum\anaconda3\lib\site-packages\rasa_core\training\”, line 207, in _merge_equivalent_nodes graph.nodes(data=True)[i]) File “C:\Users\MS066115\AppData\Local\Continuum\anaconda3\lib\site-packages\rasa_core\training\”, line 174, in _transfer_style clazzes = source.get(“class”, “”) AttributeError: ‘tuple’ object has no attribute ‘get’

Helle anointe

Could you desribe how you solved this error more in detail?