ImportError: cannot import name 'is_url'

i have started to learn this tuto Quickstart , and when i run this comand line

!python -m rasa_core.train -d domain.yml -s -o models/dialogue

i got this error message

	Traceback (most recent call last):
  File "C:\python36\lib\", line 193, in _run_module_as_main
	"__main__", mod_spec)
  File "C:\python36\lib\", line 85, in _run_code
	exec(code, run_globals)
  File "C:\python36\lib\site-packages\rasa_core\", line 16, in <module>
	from rasa_core.agent import Agent
  File "C:\python36\lib\site-packages\rasa_core\", line 38, in <module>
	from rasa_nlu.utils import is_url
ImportError: cannot import name 'is_url'

i use

PYTHON 3.6.0
RASA CORE 0.12.0
RASA NLU 0.12.0

how to solve it ? thank you

when i upgrade NLU to 0.13.0; that solve the problem, but my comande line not run i got this

usage: default [-h] [-o OUT] -d DOMAIN [--augmentation AUGMENTATION]
                    -c [CONFIG [CONFIG ...]] [--dump_stories]
                    [--debug_plots] (-s STORIES | --url URL | --core CORE)
                    [-v] [-vv] [--quiet] default: error: the following arguments are required: -c/--config

i try to follow this tutorial but not working ! what to put in the config file ?

i have created config file like this :

language: "en"

     - name: "intent_featurizer_count_vectors"
     - name: "intent_classifier_tensorflow_embedding"
     - name: "ner_duckling" # pre-trained entity recognition
     dimensions: ["email"]

Now when i run

python -m -d models/dialogue

i got this in the console :

$ python -m -d models/dialogue

2018-11-13 16:12:20 INFO     root  - Rasa process starting
2018-11-13 16:12:20 WARNING  py.warnings  - C:\python36\lib\site-packages\pykwalify\ UnsafeLoaderWarning:
The default 'Loader' for 'load(stream)' without further arguments can be unsafe.
Use 'load(stream, Loader=ruamel.yaml.Loader)' explicitly if that is OK.
Alternatively include the following in your code:

  import warnings
  warnings.simplefilter('ignore', ruamel.yaml.error.UnsafeLoaderWarning)

In most other cases you should consider using 'safe_load(stream)'
  data = yaml.load(stream)

2018-11-13 16:12:24 INFO     root  - Rasa Core server is up and running on http://localhost:5005
Bot loaded. Type a message and press enter (use '/stop' to exit):
Exception in thread Thread-2:
Traceback (most recent call last):
  File "C:\python36\lib\", line 916, in _bootstrap_inner
  File "C:\python36\lib\", line 864, in run
	self._target(*self._args, **self._kwargs)
  File "C:\python36\lib\site-packages\rasa_core\channels\", line 291, in on_message_wrapper
  File "C:\python36\lib\site-packages\rasa_core\", line 316, in handle_message
	return processor.handle_message(message)
  File "C:\python36\lib\site-packages\rasa_core\", line 86, in handle_message
	self._predict_and_execute_next_action(message, tracker)
  File "C:\python36\lib\site-packages\rasa_core\", line 305, in _predict_and_execute_next_action
	action, policy, confidence = self.predict_next_action(tracker)
  File "C:\python36\lib\site-packages\rasa_core\", line 168, in predict_next_action
	probabilities, policy = self._get_next_action_probabilities(tracker)
  File "C:\python36\lib\site-packages\rasa_core\", line 478, in _get_next_action_probabilities
	tracker, self.domain)
  File "C:\python36\lib\site-packages\rasa_core\policies\", line 288, in probabilities_using_best_policy
	if (result.index(max_confidence) ==
AttributeError: 'NoneType' object has no attribute 'index'

how it possible to solve this ?

@darkmanAmazigh I am having the same problem. Did you find a solution?