I encountered an error when I list the roles and groups of an entity in entities section of domain file

I use rasa 2.0

Here is my domain file of entities:

image

and Here is the error info when I train the model

YamlValidationException: Failed to validate ‘D:\Work\PycharmProjects\ChitChat2.0\DialogueService\domain.yml’. Please make sure the file is correct and all mandatory parameters are specified. Here are the errors found during va lidation: in D:\Work\PycharmProjects\ChitChat2.0\DialogueService\domain.yml:22: Value ‘ordereddict([(‘date’, ordereddict([(‘roles’, [‘departure’, ‘destination’])]))])’ is not of type ‘str’. Path: ‘/entities/1’

can anyone help me

thanks

How did you resolve this? I am stuck too. Please help!

Likewise - getting the same error. Has anyone been able to solve this?

@Tanja Please Help!

I’m having trouble reproducing this error. Would you be able to share more details of your configuration?

You need to use at least version 2.1. Before that version we did not allow entity roles and groups to be listed in the domain file. Please update to 2.1 and try again.

sorry ,replay late,but I did not find a solution

Even I update to 2.1, there is still an error.

The same error or something else?

It might be that your indentation is incorrect. Please make sure to use two spaces for indentation. E.g.

entities:
  - address
  - date:
      roles:
      - departure
      - destination
  - date_time
  - ow_compensation
  - ca_item

Same problem using :

"rasa": {
    "production": "2.3.1",
    "worker": "2.3.1"
},
"rasa-x": "0.37.0",
"updates": {
    "rasa-x": {
        "version": "0.37.1",
entities:
  - time
  - number
  - amount-of-money
  - PERSON
  - PRODUCT
  - rudeness
  - discipline:
      roles:
      - liked
      - disliked
  - art:
      roles:
      - liked
      - disliked
  - sport:
      roles:
      - liked
      - disliked
  - jeu:
      roles:
      - liked
      - disliked
      - expected
  - adjective:
      roles:
      - liked
      - disliked
      - expected
      - hasis

I use kubernetes environement and rasa x pod said : File “/usr/local/lib/python3.8/dist-packages/sqlalchemy/engine/default.py”, line 608, in do_execute cursor.execute(statement, parameters) sqlalchemy.exc.ProgrammingError: (psycopg2.ProgrammingError) can’t adapt type ‘dict’ [SQL: INSERT INTO domain_entity (domain_id, entity) VALUES (%(domain_id)s, %(entity)s) RETURNING domain_entity.entity_id] [parameters: {‘domain_id’: 67, ‘entity’: {‘discipline’: {‘roles’: [‘liked’, ‘disliked’, ‘expected’]}}}] (Background on this error at: http://sqlalche.me/e/13/f405)

Have you got an idea of how getting out of this ?