How to turn off Diet classifier for Entity recognition?

In the following pipeline-

  - name: ConveRTTokenizer
  - name: ConveRTFeaturizer
  - name: RegexFeaturizer
  - name: LexicalSyntacticFeaturizer
  - name: CRFEntityExtractor
  # added new
  - name: CountVectorsFeaturizer
  - name: CountVectorsFeaturizer
    analyzer: "char_wb"
    min_ngram: 1
    max_ngram: 4
  - name: DIETClassifier
    epochs: 50
  - name: EntitySynonymMapper
  - name: ResponseSelector
    epochs: 100

I just want entity results from CRFentityExtractor. So, how to turn off Diet Entity extraction?

hey @sainimohit23, If you want to use the DIETClassifier just for intent classification, set entity_recognition to False .

Sample code:

Thank you @JiteshGaikwad for your help. Can you tell me if there’s any way to set the sequence length of NLU pipeline?