How to get retrieval intent to work on 2.0.0rc1

I’m having trouble following the tutorial to getting both the chitchat and faq working.

I keep getting this error message, and not sure what I’m doing wrong

UserWarning: Your training data contains an example ‘Is it quite breezy o…’ for the chitchat/ask_weather intent. You either need to add a response phrase or correct the intent for this example in your training data. If you intend to use Response Selector in the pipeline, the training may fail.

This is what I’ve done. In, I’ve added the intent

 - intent: chitchat/ask_weather
   examples: |
    - How is the weather today?
    - What's the weather like?
    - How is the weather?
    - What is the weather at your place?
    - Do you have good weather?
    - Is it raining?
    - What's it like out there?
    - Is it hot or cold?
    - Beautiful day, isn't it?
    - What's the weather forecast?
    - Is it quite breezy outside?

I’ve created a responses.yml

    - text: "Oh, it does look sunny right now in Berlin."
      image: ""
    - text: "I am not sure of the whole week but I can see the sun is out today."

I’ve added rules to my rules.yml

> - rule: response to chitchat
>   steps: 
>   - intent: faq
>   - action: utter_chitchat

I’ve added the intent to my domain.yml and I’ve configured two ResponseSelector, to handle both chitchat and faq.

I was able to get this working on rasa 1.10.x with just one ResponseSelctor, but there, the tutorial and instructions suggested instead of using utter_chitchat, to use respond_chitchat and add an actions to the domain. However, the doc for rasa 2.0 states: Chitchat and FAQs

Rasa uses a naming convention to match a retrieval intent name to its corresponding retrieval action.

By this convention, the utter_chitchat action is configured as a response to the chitchat retrieval intent, and utter_faq is a response to faq . These actions do not need to be added to the domain file.

Should I ignore this Userwarning? Lastly, I also get this error, but I don’t see where the contradiction.

> Contradicting rules or stories found🚨
> - the prediction of the action 'utter_faq' in rule 'response to faq' is contradicting with another rule or story.
> - the prediction of the action 'utter_chitchat' in rule 'response to chitchat' is contradicting with another rule or story.
> Please update your stories and rules so that they don't contradict each other.
> You can find more information about the usage of rules at

I figured out why, in the response, you have to start with utter_[foo]. The documentation here Chitchat and FAQs uses an example that doesn’t, but the comment below clarifies.

All such responses (e.g. utter_chitchat/ask_name ) should start with the utter_ prefix followed by the retrieval intent name ( chitchat ) and the associated response key ( ask_name ).

This solved the UserWarning, and had a double intent, of faq used twice. Solved.