How to enter an empty value when using rasa interactive?

Hi there. I’m when testing my bot with rasa interactive, at the Your input -> prompt, I want to simply press <enter> to pass in an empty value to my slot.

What happens with rasa interactive is that pressing <enter> at Your Input -> brings up a list of options, Continue, Undo Last, Fork, Start Fresh, Export & Quit.

This does not happen when using rasa shell. Does anyone know why to can do <enter> at Your Input -> using rasa interactive?

Thanks… Ken

1 Like

@kchang808 I tried personally about your use case but I am not able to pass the empty value. I hope you got the answer in the today youtube stream :slight_smile: . I asked your issue with the Tayfun Sen (Senior Backend Engineer). I will suggest stick with the rasa shell then, and go for rasa interactive for checking the flow of the bot, storing values in slots, checking entities etc.

1 Like

Hi @nik202 thanks for doing that for me. Yeah it’s a inconvenient bug ( IMO ), yes, thankfully rasa shell allows an empty value which is required for my use case. BTW, I just started to have a problem with rasa run actions where I get the following error:

OSError: [Errno 10013] error while attempting to bind on address (‘’, 5055): an attempt was made to access a socket in a way forbidden by its access permissions

I’m on rasa 3.x and it was working yesterday but not today. I did try using netstat to see who is using port 5055 but there’s no one. Is your rasa run actions working fine? I am running in an conda environment per Rachael’s Windows installation procedure for 3.x.


@kchang808 Yes, that often happened with me but with port 5005, the bind address. I need to close the terminal and re run. I’m using VS code which is more convenient for me while doing so. Do again cross check next time that where is port 5055 is engaged. Do please share the error screenshot. Thanks N

Oh great, now it’s working and I don’t know why. Not that I should be complaining. Probably the wonders of Windows 10. What I did do was remote the Conda environment, reboot, got back in to the Anaconda command prompt, create the Conda environment again and install rasa following the Installation for Windows procedure as described my Rachael (Installing Rasa Open Source 3.x: Windows 10 (64 bit) - YouTube) and did the rasa init to made sure that part was working. Then I followed the Custom Actions video (Conversational AI with Rasa: Custom Actions - YouTube) just to get the in play. In VSCode I selected my rasa environments python 3.8 as the interpreter and opened up the terminal and did rasa run actions and it worked and so did the rasa shell. So I went back to my project and ran rasa run actions and it worked.

Go figure. Thanks for hanging in there with me on this issue and in my view, you are certainly deserving of the title Rasa Hero :+1:

@kchang808 Great! :+1: But, yes It option happened with my Mac Machine, and I was lucky this did not happen with my Windows Machine. I respect your enthusiasm for the problem you solved and even shared the solution with the other readers, thanks a lot for the feedback, Chang. Thanks a lot for the kind words :pray: