How create change rasa server port from 5005 to any

I have two bots, want to host in one machine but ports are same. How to change the rasa server port ??

Which version are you using? Have you tried passing the option -p 5006 for instance?

rasa==1.0.1

How are you running the bots? Can you please give me the commands so I can show you how to fix it?

rasa run -m models --enable-api --cors “*” --debug

If you want to change rasa server port, you can run the following command:

rasa run -m models --enable-api --cors “*” --debug -p 5006

You can change the port value 5006 to any port. By default, it’s 5005.

More info here: Command Line Interface

1 Like

Thanks Abdullatif

please help to resolve this issue posted on given link

how to change the port of action server, if we are using the rasa/rasa-sdk Docker image? Docker Hub