How can i use a lookup table por my entity?

I’ve been trying to use lookup tables for names. I tried it with and without regex, but I can’t make it work. First, I tried with the default pipelane. Then I tried using RegexEntityExtractor:

# No configuration for the NLU pipeline was provided. The following default pipeline was used to train your model.
# If you'd like to customize it, uncomment and adjust the pipeline.
# See for more information.
  - name: WhitespaceTokenizer
  - name: RegexFeaturizer
  - name: LexicalSyntacticFeaturizer
  - name: CountVectorsFeaturizer
  - name: CountVectorsFeaturizer
    analyzer: char_wb
    min_ngram: 1
    max_ngram: 4
  - name: RegexEntityExtractor
    case_sensitive: False
    use_lookup_tables: True
    use_regexes: True
    "use_word_boundaries": True
  - name: DIETClassifier
    epochs: 100
    constrain_similarities: true
  - name: EntitySynonymMapper
  - name: ResponseSelector
    epochs: 100
    constrain_similarities: true
  - name: FallbackClassifier
    threshold: 0.7
    ambiguity_threshold: 0.1

Still, not working. I’m on Windows 10, using rasa 3.0 This is my nlu:

- intent: presentacion_intent
  examples: |
    - soy [adriel](nombre)
    - mi nombre es [Analia](nombre)
    - me llamo [estani](nombre)
    - yo soy [Santi](nombre)

- regex: nombre
  examples: |
    - ((([aA-zZ]\w+ *){1,})+(, )*){1,}

- lookup: nombre
  examples: |
    - matias
    - eduardo
    - santiago
    - Santi
    - nelson
    - analia
    - mati
    - edu
    - adriel
    - Maria
    - marithe
    - estani

It’s in spanish, i’m sorry. ‘nombre’ is name

Hi, can you remove the below regex → remove the old model → train a new model and check again?

1 Like

will do

Thanks for answering. Stil not working though Is this Important?:

Ok, I did exactly what u told me, but it wasn’t working so now I have no regex, but changed this:

  - nombre:
    - influence_conversation: false

It’s working now! ¿what does influence conversation do? Thank you for your help!