HELP NEEDED: How to set defaul stream reading time in rasa-X

Hello dear community :vulcan_salute:

Hope you’re all doing well in these strange times. I have a question regarding the rasa-X tool. I got this Timeout.error on my local drive

But I could solve my problems locally by adjusting the following line of code to 25 seconds:


How can I adjust this “default stream reading timeout in seconds” within the Rasa-X tool?

FYI: The bot needs some time to respond, because the text needs to be analysed by a bert model.

Best regards and wished from :switzerland:


Hey @TKueng,

The error from the 1st screenshot comes from console channel of Rasa Open Source. As you’ve mentioned, DEFAULT_STREAM_READING_TIMEOUT_IN_SECONDS sets the timeout after which console channel will stop trying to read streamed answer.

How can I adjust this “default stream reading timeout in seconds” within the Rasa-X tool?

Could you please elaborate on that? Rasa X “talks” to Rasa Open Source via webhooks, and gets answers via messaging queue, no console channels are affected here. Are you somehow trying to connect console channel to Rasa X?

Hey @degiz

Thank you so much for your answer! I love the support we get in this forum. :raised_hands: What I’m trying to do, is just to make my chatbot work “online” on my server. I followed all the steps on the rasa masterclass, loaded my model and files on a github repository and displayed the chatbot on my own server. What happens there (I think) that the action action_listen is interfering with my custom action action_give_feedback (which needs around 20 seconds to respond). You think this is probable as well?

So on my server I never receive the “feedback text” that I get locally on my laptop. So my question is, if there is a possibility that my custom actions gets more time to respond proberly?

Hey @TKueng,

I see. So your custom action action_give_feedback takes some time to finish. action_listen won’t be triggered before the previous one finished, so it won’t cancel your custom one.

How long did the action_give_feedback take to finish on your local deployment? What could have happened is that your action failed for some reason. Do you have access to the logs of the action server?

Anyway, I believe that DEFAULT_STREAM_READING_TIMEOUT_IN_SECONDS won’t help here, since it’s for the console channel only.

Hello @degiz

Okay so action_listen can’t be the problem. The action_give_feedback takes about 15-20 seconds on my local drive.

What could be a tricky point is how to load my language model online. Offline I could run the following command line in my file:

def __init__(self): 
self.model = Inferencer.load("C:\\Users\\tobia\\OneDrive\\Desktop\\arguebot_test\\ModelTob")

Online I tried to adapt this line of code by loading the model via my github repository:

  def __init__(self):
  self.model = Inferencer.load("")

This a picutre from the logs, but I guess this is not the actions server?

Used the following docker-compose.yml file

version: '3.4'
    image: 'rasa/rasa-sdk:latest'
      - './actions:/app/actions'
      - '5055'
      - rasa-production

How can I access the logs of the action server?

hey @TKueng,

The log file you’ve attached is from rasa-x container, and the issue it shows failed attempt to connect to git (I guess missing .ssh pub key), the docs about git integration are here

What is the language model you’re trying to load?

To get access from the action server, you can run docker-compose logs app from the dir with your docker-compose.yml file.

Hello @degiz

The public key was not the problem, there I just mispelled the command I guess.

The language model I was trying to integrate was a German BERT Model from deepset, which therefore I needed to install the farm library from deepset and save the huge model with git lfs on my server. Now the chatbot is actually working pretty well and also responds quickly.

But I updated my file on github as well as in my server and chatbot is still referring to the old file… Do you have any clue what the reasons for that could be?

My procedure was

  • change the file on github
  • go to my directory cd /etc/rasa/argubotV1
  • sudo git pull
  • curl --request POST \ command from the masterclass episode 9
  • docker-compose up -d

But no changes…

Hi @TKueng,

Since you’ve changed files in your volume locally at ./actions you’ll probably have to remove the volume from the mount point. To do this, please run docker-compose down -v in your running deployment, and then start it up again with docker-compose up -d.

Let me know if that helps!

@ricwo worked perfectly!! Thanks a lot!!