[HELP] FileNotFoundError:No such file or directory: 'config/endpoints.yml' while building Rasa using Docker

I am trying to build rasa using docker with the given link and I keep getting this error while trying to run the command ‘sudo docker-compose up’ on ubuntu.

Please help me figure this out. I will attach the images of the docker-compose.yml file and a picture of the docker images created and my folders.

If I’m reading this correctly, your endpoints.yml file looks like it is in the same directory as your docker-compose file, yet you are telling rasa_core to look for it in the config/ subdirectory in the container. So, either move it into the config/ subdirectory or explicitly mount it there in the container and then tell rasa_core the correct path to it in the docker-compose file.

If you move endpoints.yml it into the config directory does it resolve the error?

The error was resolved. Thank you! :slight_smile:

Hi,

I face the same error. However, my endpoints.yml is in the config folder and docker-compose.yml is in the same path as my Config folder.

I specified endpoints as config/endpoints.yml. Still, it gives me that error. Could you please tell me why?

1 Like

I am also facing this problem. @Prudhvi were you able to solve it?