Google Assistant connector - error: sanic.exceptions.NotFound: Requested URL / not found

Dear users,

Currently I’m trying to create a connector for RASA and the Google Assistant. According to the tutorial the file should look like the following:

from rasa.core.agent import Agent from rasa.core.interpreter import RasaNLUInterpreter from ga_connector import GoogleConnector from rasa.utils.endpoints import EndpointConfig from rasa.core.channels import RestInput action_endpoint = EndpointConfig(url=“http://localhost:5055”) nlu_interpreter = RasaNLUInterpreter(’.PathtoNLUmodel’) agent = Agent.load(’.PathtoCore’, interpreter = nlu_interpreter, action_endpoint=action_endpoint) input_channel = GoogleConnector() agent.handle_channels([input_channel], 5004)

When I try to run, I get the following error in the CLI: " raise NotFound(“Requested URL {} not found”.format(url)) sanic.exceptions.NotFound: Requested URL / not found"

Does anyone know what the problem is?


Update: Rasa version 1.0.6

Hi there,

We are working on updating this tutorial to the latest rasa versions!

1 Like

Hi @erohmensing

when this update is completed?

I wait for it

We will let you know :slight_smile:

Hi @erohmensing, Is it going to take long? Could someone please suggest an alternate option for speech to text (and text to speech) conversion meanwhile to be integrated with rasa? on-premise is preferred.

Hi, the blog tutorial about connecting rasa to google assistant has updated. It works well in rasa 1.0.

@deeppark sorry I didn’t come back to this thread to let you know. @paraparata is right, it’s been updated! Another STT you might be interested in is Mozilla Deepspeech.

I just tested it and it’s working like a charm. Thanks a lot @paraparata and @erohmensing for confirming.

1 Like

Thank @Juste, she did all the work of updating it! :heart:

1 Like

Thanks @Juste :slight_smile:


Hi @Juste and @erohmensing, I see an issue with, it only sends single utterance at a time to google assistant and all other utterances are ignored. I have scenarios where I need to utter multiple messages like “sure can do” and then send actual message. but I see only uses first message and send it to assistant. Also buttons aren’t working either.

Hey @deeppark. The current state of the connector is definitely simple and there are lots of things that could be improved. Would you be up for making a contribution to it? Feel free to open a PR with your suggestions and improving it. It would be a great way to become a Rasa contributor :slight_smile:

1 Like

Sure. I’ll give it a try.

1 Like

Hi @deeppark have you found a solution to this issue? I am also facing the same problem

@ushan i haven’t worked on it. I appreciate developers take time from there busy schedule and contribute. Unfortunately not working for me.

Hi, @erohmensing I have tried following the same updated tutorial on connecting with Google assistant, but is facing the same problem as originally stated in the opening of this post: sanic.exceptions.NotFound: Requested URL /webhooks/google_assistant/webhook not found

FYI, I am running Rasa on Ubuntu. The Rasa version is only recently installed and should be up to date. Any suggestion on how this has been resolved (as not evident from the above replies) would be appreciated

@wching did you add the google assistant credentials to your credentials.yml? You can run the server with rasa run --debug to see the list of endpoints that are available uplon server start.

@erohmensing thanks, and after adding back the GA credentials, it works! I used my own chatbot so forgot to include this in the beginning. Thanks for the prompt reply !

No problem, glad you got it worked out! :slight_smile:

1 Like