Getting Rest API URL and Request Params for Rasa x agent in a server

I have installed Rasa X on a VPS(Virtual Private Server) using one line deploy script by following the documentation One-Line Deploy Script using the command curl -s | sudo bash.

Now I want to get the Rest API URL and request format for the deployed agent to test in a mobile app.

Thank in advance.

1 Like

Hi @senthurRam, welcome to the forum!

Not sure I understand your question completely, but the REST API is available at <host>/api. For a full API specification please check the docs on the Rasa X HTTP API .

Let me know if that helps!

1 Like

Hi @ricwo thanks for the reply but I need the chat API to send the text and get the response from the chat agent in rasa x

1 Like

Bump on this, installed with one-line curl, use to be able to sort it out with Rasa, but with Rasa X no idea how to get rest working. Any ideas???

@senthurRam, @FelixKing I assume you’re talking about the REST input channel? This section in the docs on the One-Line Deploy Script describes to do that - you can run the script with

curl -s | sudo -E bash

I hope that helps!

@ricwo I have added the ADDITIONAL_CHANNEL_CREDENTIALS in environment variable as stated above and then executed the one line deploy script but still I’m not able to access the messaging Rest API


It show error as Error: Requested URL /webhooks/rest/webhook not found

1 Like

have you tried localhost/core/webhooks/rest/webhook?

I found another thread where they were using /core before webhooks and they got it to work, let me know if that works!

@FelixKing I have tried adding /core before webbhooks, but still it shows as Error: Requested URL /webhooks/rest/webhook not found.

Can you share a full stacktrace of the error?

Did you run the bash command with the -E flag, i.e. curl -s | sudo -E bash?

I just gave it a try and the REST input channel works with the method mentioned earlier:

curl -s | sudo -E bash

note the -E in the bash command. You can then access it at <IP>/webhooks/rest/webhook. I hope that helps!

I attempted this on my current install and I received the same results as prior, and that @senthurRam Error: ‘’ not found

So I went and spun up another VPS ran both of the steps, expor & curl and it looks like its working. If you visit the url of /webhooks/rest/webhook it will toss up another error, and its working! I can send a curl command and get a response, and it also shows up in Rasa X, which a REST method.

@senthurRam Try to reinstall, I have a git connected so it wasn’t too difficult, once I did a fresh install, connected git, trained, I was able to send this command from terminal and get a proper response

curl -d ‘{“sender”: “Rasa”, “message”: “Hi”}’

curl --request POST
–url http://IPADDRESS/webhooks/rest/webhook
–header ‘content-type: application/json’
–data ‘{ “message”: “Hello” }’

and received the response

[{“recipient_id”:“default”,“text”:“Hey! How are you?”,“buttons”:[{“payload”:“great”,“title”:“great”