Getting error: Exception occurred while handling uri: unknown [NoneType : none]

I did train a model with few intents and custom actions. Rasa run shell works appropriately. I was trying to access the rasa chatbot from a custom web page. I started rasa using the following command: rasa run --enable-api --log-file out.log in another console started action server: rasa run actions.

The launched the webpage using the client approach discussed in: GitHub - scalableminds/chatroom: React-based Chatroom Component for Rasa Stack

chatroom page does not seem to retrieve anything from rasa. What am I missing? The url in the webpage: host: “http://localhost:5005”, Error: [2020-07-08 16:38:57 -0500] [44728] [ERROR] Exception occurred while handling uri: unknown NoneType: None

Do I have right url?

if I change the url to: host: “http://localhost:5005/webhooks/rest/webhook”, error:

[2020-07-08 16:54:40 -0500] [44728] [ERROR] Exception occurred while handling uri: ‘http://localhost:5005/webhooks/rest/webhook/webhooks/rest/webhook’ Traceback (most recent call last): File “c:\users\rsripad\appdata\local\continuum\anaconda3\envs\rasa-new\lib\site-packages\sanic\app.py”, line 940, in handle_request handler, args, kwargs, uri, name = self.router.get(request) File “c:\users\rsripad\appdata\local\continuum\anaconda3\envs\rasa-new\lib\site-packages\sanic\router.py”, line 411, in get return self._get(request.path, request.method, “”) File “c:\users\rsripad\appdata\local\continuum\anaconda3\envs\rasa-new\lib\site-packages\sanic\router.py”, line 475, in _get raise NotFound(“Requested URL {} not found”.format(url)) sanic.exceptions.NotFound: Requested URL /webhooks/rest/webhook/webhooks/rest/webhook not found

Am I missing something in credentials yml? rest:

pass

Any help is greatly appreciated.

Resolved after changing: rasa run --log-file out.log --cors * --enableapi appears cors should be rest to all.

I am also facing the same issue - Please help. I am using -

rasa run -m models --enable-api --cors “*” --debug

please suggest what need to be changed to resolve this.

Regards,

Command that worked for me is: rasa run --log-file out.log --cors * --enable-api