FutureWarning: The definition of slot mappings in your form should always be preceded by the keyword `required_slots`. f"The definition of slot mappings in your form "

Hi, I am using Forms for slot_filling but am getting this error followed by this error:

UserWarning: Loading domain from ‘domain.yml’ failed. Using empty domain. Error: ‘The slot mappings for slot ‘required slots’ in form ‘ll_form’ have type ‘<class ‘dict’>’. It is required to provide a list of slot mappings. Please see Forms for more information.’

As a result my domain file is not being detected and my core model is not getting trained. Grateful for any help :pray::pray:

@sanikachepe Hi, can you please share the domain.yml file? Or @sanikachepe Update the Rasa Version.

Hi, this actually looks more like your domain file isn’t being found. (UserWarning: Loading domain from ‘domain.yml’ failed). Have you tried specifying the path to the domain like so: rasa train core --domain <path/to/domain.yml>?

Hi, I tried running this command but I am getting the same error.

@sanikachepe your rasa version?

@sanikachepe can you update the rasa version? or you can create the new environment for updated version, train the model and run again?

Is it necessary though? Because a test form was working fine… I’ll try it nonetheless

Can you check if there is any error in my domain file?

@sanikachepe can you please read the from_text section and check your domain Forms

@sanikachepe got your error…

add _ in required slots in domain file please and you will be good to go.


Thank you!

1 Like