Facebook Webhook Address Not Working

During this stage of the Facebook Messenger setup:

Set up a Webhook and select at least the messaging and messaging_postback subscriptions. Insert your callback URL which will look like https://<YOUR_HOST>/webhooks/facebook/webhook . Insert the Verify Token which has to match the verify entry in your credentials.yml

Facebook cannot find the webhook address. I have tried this on a server and on my local PC (with ngrok address). I cannot resolve it on Facebook or on my web browser.

What step am I missing?

1 Like

I think it’s due to an SSL/TLS problem. What error is shown in rasa logs when you click verify?

@ameid - Not quite sure how to check the Rasa logs or more specifically which ones? I did go through the forum but I found several ways to log. Could you tell me the way you set it up? - Thank you in advance!

An easy way to check the logs is in the command line interface where you’re starting the server.

I’m still figuring out a way to set it up to be honest.

I had to include the --api, --endpoints, --credentials, and --log command with “Rasa run”

I had to edit endpoint.yml to uncomment the following on my local install:

#  url: "http://localhost:5005/webhook"

I use Anaconda on Windows 10 just FYI for anyone reading. Here is the full command:

rasa run -m models --credentials credentials.yml --enable-api --log-file out.log --endpoints endpoints.yml

For others, if you used docker, it should look something like:

docker run -v $(pwd):/app rasa/rasa run -m models --credentials credentials.yml --enable-api --log-file out.log --endpoints endpoints.yml

One last note is that Facebook Webhook only takes “https” so when you run ngrok on your local install, they provide you both http/https - so make sure you use the https URL.