Error when installing rasa x 0.42.5

Hi community,

I have encountered an error when I tried to install rasa x on my laptop using Local Mode. I cannot start Rasa X while I can talk to my bot using rasa shell. I am delighted if you can help me trace this issue. Thank you for your kind attention!

I have also exported the error log using rasa x --debug, please find it here β†’ errorMessage.txt (14.7 KB)

Rasa Version : 2.8.14 Minimum Compatible Version: 2.8.9 Rasa SDK Version : 2.8.2 Rasa X Version : 0.42.5 Python Version : 3.8.12 Operating System : Windows-10-10.0.19042-SP0 Python Path : C:\Users\tszch\anaconda3\envs\rasa\python.exe

Welcome to the forum :slight_smile:

Please see if this post can help: Rasa X runs with several Errors & Warnings - #2 by nik202

Thank you @ChrisRahme, it helped. I had read the post before and the solution worked in my environment. I am just curious about a point that whether Python 3.8.11 supports a newer version of Rasa (and later, Rasa 3.0 maybe) or not. Would you recommend an upgrade for the Python version or stick to the old suit?

@arthurchan Well, currently Rasa support 3.6,3.7 and 3.8 but not 3.9 but yes as rasa update their version, sure rasa and rasa x will run on later versions of python. The good news it that 3.0 soon will be official and I’d recommend stick on the current version of Python and Configuration of Rasa working on your environment. Later, you can upgrade. I hope this information helped you and solve your issue.

Please can you confirm, what is your rasa --version and share the screenshot.