Error running Rasa X

I am new to Rasa. I am trying to use Rasa X, with the sample example provided on the Rasa website. When I run rasa x, I am getting the following error. The OS is Ubuntu 18.04 LTS

/home/mohit/anaconda3/lib/python3.6/site-packages/h5py/ FutureWarning: Conversion of the second argument of issubdtype from `float` to `np.floating` is deprecated. In future, it will be treated as `np.float64 == np.dtype(float).type`.
  from ._conv import register_converters as _register_converters
free(): invalid pointer
Aborted (core dumped)

At which point does this exactly happen? Could you please run rasa x with the--debug flag and post the output here? Also, how much memory do you have?

Welcome to the community btw!

What I observed later that it was happening to rasa train and rasa shell also after I installed rasa x. I uninstalled all rasa packages and went back to the old setup using requirements.txt used from medical locator example on your site and rasa train/shell started running fine. However installation was showing error regarding some libraries incompatibility. However when I used the following command:

pip install rasa[spacy]
python -m spacy download en_core_web_md
python -m spacy link en_core_web_md en

The same error came back, so I had to do the re-installation again.

I will install rasaX again to recreate the scenario, I described above.

My computer has 32 GB of memory and NVIDIA 1060 GPU with 6 GB memory

I hope this helps,


Just reinstalled rasa-x in a separate conda environment and everything seems to be good now.

Thank you