Error using starter-pack-rasa-stack

Hey I installed all the libraries but running this seems to throw an error with Python 3 vs 2. Any suggestions?

(env) BL-C02TP2MHHTD8:starter-pack-rasa-stack danielw$ make cmdline
python -m -d models/current/dialogue -u models/current/nlu --endpoints endpoints.yml
/Users/danielw/rasa/env/lib/python3.6/site-packages/h5py/ FutureWarning: Conversion of the second argument of issubdtype from `float` to `np.floating` is deprecated. In future, it will be treated as `np.float64 == np.dtype(float).type`.
  from ._conv import register_converters as _register_converters
2019-01-22 22:49:28 INFO     root  - Rasa process starting
2019-01-22 22:49:41 INFO     rasa_nlu.components  - Added 'nlp_spacy' to component cache. Key 'nlp_spacy-en'.
Traceback (most recent call last):
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/sklearn/externals/joblib/", line 508, in _unpickle
    obj = unpickler.load()
  File "/Users/danielw/.pyenv/versions/3.6.7/lib/python3.6/", line 1050, in load
  File "/Users/danielw/.pyenv/versions/3.6.7/lib/python3.6/", line 1184, in load_binstring
  File "/Users/danielw/.pyenv/versions/3.6.7/lib/python3.6/", line 1166, in _decode_string
    return value.decode(self.encoding, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0x8b in position 24: ordinal not in range(128)

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/Users/danielw/.pyenv/versions/3.6.7/lib/python3.6/", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/Users/danielw/.pyenv/versions/3.6.7/lib/python3.6/", line 85, in _run_code
    exec(code, run_globals)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_core/", line 246, in <module>
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_core/", line 48, in create
    return RasaNLUInterpreter(model_directory=obj)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_core/", line 282, in __init__
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_core/", line 298, in _load_interpreter
    self.interpreter = Interpreter.load(self.model_directory)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_nlu/", line 293, in load
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_nlu/", line 320, in create
    model_metadata, **context)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_nlu/", line 419, in load_component
    cached_component, **context)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_nlu/", line 134, in load_component_by_name
    return component_clz.load(model_dir, metadata, cached_component, **kwargs)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/rasa_nlu/extractors/", line 371, in load
    ent_tagger = joblib.load(model_file)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/sklearn/externals/joblib/", line 578, in load
    obj = _unpickle(fobj, filename, mmap_mode)
  File "/Users/danielw/rasa/env/lib/python3.6/site-packages/sklearn/externals/joblib/", line 523, in _unpickle
    raise new_exc
ValueError: You may be trying to read with python 3 a joblib pickle generated with python 2. This feature is not supported by joblib.
make: *** [cmdline] Error 1

Hey just checking in if anyone’s seen this. I’ve tried installing 3.6.4 of Python and updating my rasa packages to the latest version.

This only happens when I run the make cmdline command.

I think you train the model with python 2, and now use python 3 to use model and run the bot. This may cause some encoding problems.