Error rasa train

YamlValidationException: Failed to validate ‘C:\Users\Syed Mohammed Bilal\CHATBOT\domain.yml’. Please make sure the file is correct and all mandatory parameters are specified. Here are the errors found during validation: in C:\Users\Syed Mohammed Bilal\CHATBOT\domain.yml:24: Value ‘[ordereddict([(‘name’, ordereddict([(‘type’, ‘text’)]))]), ordereddict([(‘subject’, ordereddict([(‘type’, ‘text’)]))])]’ is not a dict. Value path: ‘/slots’ can anyone tell me what error i have

@SyedBilalHasan can you share the proper screenshot of above error or please format the code. @SyedBilalHasan please share the domain.yml file for us.

Sure here it is

here is the error

@SyedBilalHasan I asked for file, this is screenshot. please upload domain.yml file.

here it is domain.yml (4.5 KB)

@SyedBilalHasan can you delete - in line 17 after ( - Technological_Contests_For_middle_section ) please and run the code and share with me file again.

@SyedBilalHasan why do you have intents starting with capital letters? Any specific reason?

Hi yeah so i actually had to add more intents to my file so here it is and to answer your question regarding the intents . I did not have any reason to start the intent names with capital letters although i did not know that would have an effect on what i do . domain.yml (4.9 KB)

@SyedBilalHasan your error still persist that you not told me? can you share error screenshot?

Hi it is the same error


change this and run.

    type: text
    type: text

@SyedBilalHasan Is this error solved, you not acknowledged?

Hi yes it is I am sorry that i forgot about it

@SyedBilalHasan Ok, No worries. Happy to help you!

1 Like