Error installing Rasa X, building dependencies

I’m getting an AttributeError trying to install Rasa X inside a virtualenv with python3.6. It seems to be a problem when building dependencies.

I ran pip install rasa-x --extra-index-url from my activated virtualenv.

Here’s the trace. Hope you can help me out! Rasa X seems great! I’m really eager to give it a try :slight_smile:

ERROR: Complete output from command /home/nico/.virtualenvs/py3emi/bin/python3 /home/nico/.virtualenvs/py3emi/lib/python3.6/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-uta1ss_4/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i --extra-index-url -- 'setuptools>=30.3.0' wheel setuptools_scm==3.2.0:
  ERROR: Traceback (most recent call last):
    File "/usr/lib/python3.6/", line 193, in _run_module_as_main
      "__main__", mod_spec)
    File "/usr/lib/python3.6/", line 85, in _run_code
      exec(code, run_globals)
    File "/home/nico/.virtualenvs/py3emi/lib/python3.6/site-packages/pip/", line 16, in <module>
      from pip._internal import main as _main  # isort:skip # noqa
    File "/home/nico/.virtualenvs/py3emi/lib/python3.6/site-packages/pip/_internal/", line 4, in <module>
      import locale
    File "/home/nico/.virtualenvs/py3emi/lib/python3.6/", line 16, in <module>
      import re
    File "/home/nico/.virtualenvs/py3emi/lib/python3.6/", line 142, in <module>
      class RegexFlag(enum.IntFlag):
  AttributeError: module 'enum' has no attribute 'IntFlag'
ERROR: Command "/home/nico/.virtualenvs/py3emi/bin/python3 /home/nico/.virtualenvs/py3emi/lib/python3.6/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-uta1ss_4/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i --extra-index-url -- 'setuptools>=30.3.0' wheel setuptools_scm==3.2.0" failed with error code 1 in None

I wish I had an answer for you, I am eager as well, I think they need a troubleshooting page along side the install. I ran into an issue as well and since it’s so new I haven’t found any troubleshooting help. Hopefully soon

People here suggest, that the enum34 module could be installed as a dependency by another package and thus masks the enum package from python itself.

Try checking if the enum34 module has been installed and if so, uninstall it first, before trying to install rasa-x

1 Like

@nicoTrombon have you managed to resolve it with the info provided in that link? Sadly I haven’t encountered this issue so far.

@FelixKing what kind of issues did you have?

Great to see you all trying out Rasa X!

1 Like

Hi @tomtomtom and @akelad, thanks! I’ll try checking the enum34 module, to see if it has something to do and I’ll let you know!

It worked! Thank you @tomtomtom!

Glad you got it working! Would you both be up for filling out a feedback form once you’ve used Rasa X a bit? Product Feedback - Rasa X