Error in online training with Rasa

I follow a tutorial and created two modules for training my chatbot based in a domain and stories, but when I running the online training module, the follow errors appears:

    /env/rasa/lib/python3.6/site-packages/sklearn/preprocessing/ DeprecationWarning: The truth value of an empty array is ambiguous. Returning False, but in future this will result in an error. Use `array.size > 0` to check that an array is not empty.
  if diff:

But it is possible ignore this and continue executing, but in the final steps of my storie, crashs and show this: exception occurred while recording messages.
Traceback (most recent call last):
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 1286, in record_messages
    finetune, sender_ids, plot_file)
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 863, in _predict_till_next_listen
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 1220, in _plot_trackers
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 453, in visualize_neighborhood
    _merge_equivalent_nodes(graph, max_history)
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 204, in _merge_equivalent_nodes
    _nodes_are_equivalent(graph, i, j, max_history):
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 148, in _nodes_are_equivalent
    _fingerprint_node(graph, node_a, max_history) ==
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 115, in _fingerprint_node
    for continuation in continuations}
  File "/home/henrique/Documents/env/rasa/lib/python3.6/site-packages/rasa_core/training/", line 115, in <setcomp>
    for continuation in continuations}
TypeError: sequence item 1: expected str instance, dict found

Searching in forums a solution is update the numpy but it’s don’t work. Sorry, but I cannot expose more details because I don’t have experience with Rasa before.

I got the same Error. Please we need for help.

I had the same issue. I am also not sure what happens here, in my case the following happens:

  1. I am running a FormAction
  2. the bot asks for a piece of requested information in an attempt of filling a slot, and
  3. the response intent is misunderstood, i.e. the requested slot can not be extracted.
  4. Here, sth goes wrong because the bot asks for the slot again, but will not listen to the answer but predicts some custom action.
  5. Therefore, I correct the next action to action_listen
  6. and then online training crashes with the above error message.

I guessed it should be sth with the visualization (as according to the last error message), that somehow the graph cannot loop back when the intent was misunderstood while the FormAction was active.

Not sure if the above helped describing the issue, I am also quite in the dark about it but it would be nice to get an answer to this. @Ghostvv, maybe you could help us out?

Ok, I don’t know exactly what happens, but I followed the first tutorial weatherbot using the last Rasa version, and adapt a lot of things. Then, this errors appears and the learning of my data is not very good. I checked the versions of libs used in the original project that I based my own and simply download the requirements of the update project weatherbot and all works very well.

About the error, I don’t have sure, but some of errors disappear when I explicity determine in my stories the flow of conversation with consistent number of examples.

So, I guess you are right and we just need to introduce some more unhappy paths in the training data. That seems to have eliminated this issue most of the time.

The error is odd. How does your domain file look like? Did you create any actions in the interactive learning session?

Hi, @tmbo,

My domain file is:

- utter_ask_infrastructure
- utter_goodbye
- action_sendAssistance
- utter_ask_infrastructure_
- utter_start_service
- utter_ask_registry
- utter_ask_burst
- utter_ask_check
- utter_greet
- utter_ask_pre_service
- utter_not_understand
- utter_ask_how_long
- action_check
- location
- registry
- greet
- agree
- inform
- goodbye
- refuse
    type: text
    max_value: 1.0
    min_value: 0.0
    type: float

I don’t create any action during the interactive learning.

@tmbo Im facing the same error.Unable to determine which is causing this error

@Prabha I am getting the same error. Did you manage to solve it?

I got the same problem. Anyone can help me. I can’t do anything. Please. For more information from mantigames.

@sagari, This issue has been labelled as ‘bug’ by RASA in github pages.It still persists,however it is not impacting my training to that extent. I’m getting this error once in a while and i re-initiate my training process. No specific fix for this issue.

@prabha Thanks for letting me know. I hope they fix it.

You can fix this issue by exporting user stories every time interactive learning returning one value in the slot. This seems to be rasa doesn’t have mechanism when there are more than two values returning in the same slot.