Error during rasa installation: Failed building wheel for ujson

Hello, I keep getting this error during rasa installation :

./deps/double-conversion/double-conversion\ fatal error C1083: Cannot open include file: ‘math.h’: No such file or directory error: command ‘C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\VC\Tools\MSVC\14.29.30037\bin\HostX86\x64\cl.exe’ failed with exit status 2

ERROR: Failed building wheel for ujson Failed to build ujson ERROR: Could not build wheels for ujson which use PEP 517 and cannot be installed directly

I’m trying to install the 1.10.2 version within the conda environment, and any other 1.X.X gives me this error. Python: 3.7 ( I even tried to install ujson before starting to install rasa, but I still get the same error ) Thanks in advance

@chayy24 If you are trying to install the rasa using VS code, then check your VS code and Build tools for the same or install the latest VS code.

More info please follow this thread from starting and follow the issue as per your need: Windows installtion of Rasa x - #14 by nik202

@chayy24 I will recommend using the latest rasa open source if you are only interested in rasa open-source.

create a project folder rasa

    1. conda create -name “Your_Environment_Name” python=3.8 or python==3.7
    2. conda activate Your_Environment_Name
    3. pip install pip==20.2 or go with latest
    4. pip install rasa-sdk==2.8.1
    5. pip install rasa==2.8.0
    6. rasa init     follow the instructions
    7. running rasa type rasa shell 
    8. for training the bot rasa train
    9. In new separate terminal for custom action i.e run rasa run actions

If you found any dependencies try install them only which shows >= only.

Further, if you are unable to install or get any errors share the screenshot. Good Luck!