Error botocore & dateutil after requirements.txt update


Since last update of the requirements.txt file from RASAHQ/rasa repo, we had an error started to pop when installing the framework (on any environment) :

ERROR: botocore 1.13.25 has requirement python-dateutil<2.8.1,>=2.1; python_version >= "2.7", but you'll have python-dateutil 2.8.1 which is incompatible.

While this will look pretty obvious to many of you (all?) I’m no dev and it took me an entire day to fix. Thus my question : Is there any place here on the Community Forum or on Rasa website to watch and get last news update so I optimize my time trying to figure out why my installation process doen’t work anymore ?



Looks like a pinning issue on botocore project, which broke a lot of downstream projects:

1 Like

I faced the same problem on Ubuntu 19.04, running Python 3.7.3. I used the following command to get rid of the dateutil error pip install -U python-dateutil==2.80 and then encountered the httptools build fail error. To solve that I ran sudo apt-get install python3-dev To reinstall the header files and static libraries for python dev.

I ran pip install rasa again after two commands above and it works.

1 Like