Entities can't get extracted with regex

Hey guys, how are you? I need help, probaly a missed something about entities extractor with regex, i’ve try everthing that i found on the docs but nothing work, sorry about my english, i’m no native speaker but i will take this opportunity to risk write a litle bit hahah pls, look this. My stories:


My nlu:


My domain:

This runs perfect, or almost. I need catch this numbers callled “cpf” and put them on the cpf_slot, the intention predict its look like a divine job, its super higth, but the entity don’t come together, look this photo:

more than 99% of similarity in the intention but nothing about the entities? I know that, the classification and the extraction methods its a diferent thing, but this sounds very strange to me. Anyone can help me please? I don’t have hair anymore :cry:

The “rule” wrote in the first photo is not the problem, i’ve try everthing, with rules and stories hahah, plis, ignore that…

Hello and Welcome to the forum @Wedrano-de-Carvalho.

can you please share the config.yml file and rasa --version?

Yaaaahhh, hellooo o/

shure, my config file its all commented, i’m using the RASA default configs…

and the version


one more observation, in the first photo the entity name was diferent, this also isn’t the problem, i already changed that

Hey, i completed the discobot tutorial and i see that i have to mark the peaples with the ‘@’ hahah so i try it marking you @nik202 auhsaushuashu

@Wedrano-de-Carvalho can you uncomment the config.yml file and try run?

@nik202 Didn’t work :smiling_face_with_tear:

I trained again and nothing change

@Wedrano-de-Carvalho delete older trained model please and try again. Did you mentioned the RegexEntityExtractor in config.yml please ref this link: NLU Training Data

@nik202 I already have delete the other models, now i’m replace RegexFeaturizer to RegexEntityExtractor, but when i run rasa train command, this messages is printed:

but when i run the regex in jupyter notebooks, it’s all right: 10

@Wedrano-de-Carvalho you trained the model successfully?

@nik202 yes, but that message is printed every time i run the rasa, and the entity is not extracted

@Wedrano-de-Carvalho do you have nlu examples based on your regex?

@nik202 what do you mean with that? in my nlu.py file? if that’s what you mean, i have: 2

@nik202 hey, i got it!! yohohohohoh i changed the nlu text format to this 12

now its work!! thank’s a lot for you attention bro, you are the best!!

@Wedrano-de-Carvalho please close this thread please as a solution while Entities can't get extracted with regex - #14 by nik202 , it will be 250 :slight_smile: and good luck!

@nik202 I don’t know how i close this topic kk

@Wedrano-de-Carvalho Thanks you marked the right solution.