Docker with rasa-sdk image

juste
(Argideritzalpea) #1

I am running the rasa-sdk container. I have changed the constants.py file to hold the default port 5056 (the port I want the action server to run through), committed the image, and start the image as a new container.

I am trying to set up multiple containers on different ports. I’d like the action server to be on 5056, and the port to my Twilio channel to be 5200. Anyone know what I need to change or what I’m missing?

Docker ps doesn’t mention anything about port 5200:

Here’s my docker-compose.yml:

version: '3.0'
  
services:
  rasa:
    networks: ['rasa-network']
    image: /rasa:v0.1
    #build:
    #  context: .
    #  dockerfile: Dockerfile-rasa
    ports:
    - "5006:5006"
    volumes:
    - ./:/app
            #- "./models:/app/models"
            #- "./data:/app/data"
      #- "./rasa:/usr/local/lib/python3.6/site-packages/rasa"
    command: run --enable-api --model models --p 5200 --connector twilio --credentials credentials.yml --endpoints endpoints-twilio-docker.yml

  action_server:
    image: /crowdy:5056test
    networks: ['rasa-network']
    ports:
    - "5056:5056"
    volumes:
    - "./actions:/app/actions"

  duckling:
    image: rasa/duckling:latest
    networks: ['rasa-network']
    ports:
    - "8000:8000"

networks: {rasa-network: {}}