Custom Action Server

Hi,

I want to configure a custom action server that is running as a separate pod. I am currently using the Rasa X helm chart for setting it up.

I have made the following changes in the values files:

app:
  install: false
  endpoints:
    healthCheckUrl: http://some-ms/health
    actionEndpointUrl: http://some-ms/customAction

I am facing an issue here when I try to train the model. The action name has been specified in the domain file, under the actions and has also been mentioned in the training data of a story. However, when I train the model, the worker throws an error telling that the action was not found.

Can someone please help me out here?

Can you pu the complete error message ?

I am yet to use Rasa X helm chart, but I believe it shouldn’t affect your model training, perhaps there is a misspelling on your actions

raise ActionNotFoundException(

rasa.shared.core.domain.ActionNotFoundException: Cannot access action ‘action_hello_world’, as that name is not a registered action for this domain. Available actions are:

actions:

  • action_hello_world

This is the line in the domain.yaml file.

=================================

To avoid this scenario, I also tried to do this via a python action server and I am getting the same error.

2021-07-13 11:13:21 INFO rasa_sdk.endpoint - Starting action endpoint server… 2021-07-13 11:13:21 INFO rasa_sdk.executor - Registered function for ‘action_hello_world’. 2021-07-13 11:13:21 INFO rasa_sdk.endpoint - Action endpoint is up and running on http://0.0.0.0:5055

There are the logs in my custom action pod which has been deployed on K8s

Can you share your Domain.yml file ?

Here it recognize the the actions is indeed in your python script, however, I still believe there might be something missing on your domain file.

I removed one of my actions from the domain file on propose and I got the following error:

ActionNotFoundException: Cannot access action 'action_utter_usefulness_deny', as that name is not a registered action for this domain. Available actions are:
- action_test_1
- action_test_2
- action_test_3

The ActionNotFoundException: usually happens when you have an action in your stories and not on your domain.

Would be awesome if you could share your domain structure so we can rule this out