'cupy.core.core.Indexer' has no attribute '__reduce_cython__'

Hi Rasa community,

I am new to Rasa. I have just install Rasa on Win10, with a venv. The install went smoothly.

But when I have tried to reproduce the Jupyter notebook shown by Justina during the NYC PyConf, I have an issue when I run the NLU model training.

The error is : ‘cupy.core.core.Indexer’ has no attribute ‘reduce_cython

I have install the latest version of Rasa and Rasa X. I have remove all previous cuda and install a fresh Cuda 10.0 I have install space[cuda100] I have check my laptop configuration in order to use always the NVidia GPU I have check cuda version (10.0) I have check nvdia-smi … My pip freeze is : cupy-cuda100==7.0.0b4 … rasa==1.3.9 rasa-sdk==1.3.3 rasa-x==0.21.4 … spacy==2.2.1 … tensorboard==1.14.0 tensorflow==1.14.0 … tensorflow-gpu==1.14.0

So I do no see what to do…

Thanks for your precious help.

Best regards


I believe somethings going on with your cuda installation - I’m not quite sure how to resolve that. You can however try using a venv with a non gpu version of tensorflow, you generally don’t need to train Rasa models on a GPU.